summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarlo Holl <carloholl@gmail.com>2020-10-31 19:02:24 -0700
committerChristopher Baines <mail@cbaines.net>2020-11-01 13:34:44 +0000
commit9b3b327a4a29079b39ced0abb952874abbf921a0 (patch)
tree91020da206dd74af59dbc3947a947b0da05beab6
parent0ff9a717f6588f956b6a5d1593223473fa274bb2 (diff)
downloadguix-patches-9b3b327a4a29079b39ced0abb952874abbf921a0.tar
guix-patches-9b3b327a4a29079b39ced0abb952874abbf921a0.tar.gz
gnu: Add ghc-decimal.
* gnu/packages/haskell-xyz.scm (ghc-decimal): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/haskell-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index bed57150d5..7ec38e357b 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -2987,6 +2987,35 @@ to add D-Bus support to Haskell applications, without the awkward
interfaces common to foreign bindings.")
(license license:asl2.0)))
+(define-public ghc-decimal
+ (package
+ (name "ghc-decimal")
+ (version "0.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/Decimal/Decimal-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0k7kh05mr2f54w1lpgq1nln0h8k6s6h99dyp5jzsb9cfbb3aap2p"))))
+ (build-system haskell-build-system)
+ (native-inputs
+ `(("ghc-hunit" ,ghc-hunit)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-test-framework" ,ghc-test-framework)
+ ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)
+ ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)))
+ (home-page "https://github.com/PaulJohnson/Haskell-Decimal")
+ (synopsis "Decimal numbers with variable precision")
+ (description
+ "A decimal number has an integer mantissa and a negative exponent.
+The exponent can be interpreted as the number of decimal places in the
+value.")
+ (license license:bsd-3)))
+
(define-public ghc-deepseq-generics
(package
(name "ghc-deepseq-generics")