summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-12-07 22:49:07 +0100
committerAndreas Enge <andreas@enge.fr>2013-12-07 22:49:07 +0100
commit91318a9e1974d12c55be39f7ea8d4388950e0997 (patch)
treed9a729f1b71ad9b19f955047ce497356c5d5e7e7
parente426106bd1a67f9ac8a1a1b52a51968b7944422f (diff)
downloadguix-patches-91318a9e1974d12c55be39f7ea8d4388950e0997.tar
guix-patches-91318a9e1974d12c55be39f7ea8d4388950e0997.tar.gz
gnu: Add perl-http-message.
* gnu/packages/web.scm (perl-http-message): New variable.
-rw-r--r--gnu/packages/web.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 905b854d6a..3e1f76235d 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -193,3 +193,27 @@ exists it is used instead.")
automatically determining its encoding. It uses the HTML5 encoding sniffing
algorithm specified in section 8.2.2.1 of the draft standard.")
(home-page "http://search.cpan.org/~cjm/IO-HTML/")))
+
+(define-public perl-http-message
+ (package
+ (name "perl-http-message")
+ (version "6.06")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/G/GA/GAAS/HTTP-Message-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0qxdrcak97azjvqyx1anpb2ky6vp6vc37x0wcfjdqfajkh09fzh8"))))
+ (build-system perl-build-system)
+ (inputs
+ `(("perl-http-date" ,perl-http-date)
+ ("perl-io-html" ,perl-io-html)
+ ("perl-lwp-mediatypes" ,perl-lwp-mediatypes)
+ ("perl-uri" ,perl-uri)))
+ (license (package-license perl))
+ (synopsis "Perl HTTP style message")
+ (description
+ "An HTTP::Message object contains some headers and a content body.")
+ (home-page "http://search.cpan.org/~gaas/HTTP-Message/")))