summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-12-07 22:42:18 +0100
committerAndreas Enge <andreas@enge.fr>2013-12-07 22:42:18 +0100
commit24b3c0533d600d157bf9ec1cd0f5cf78a47348a3 (patch)
tree6d5a964be31b36fdc6f86fe96124e2a6301db943
parentfea5ebb106e72b003dc66dfd77779dc09dd80e67 (diff)
downloadguix-patches-24b3c0533d600d157bf9ec1cd0f5cf78a47348a3.tar
guix-patches-24b3c0533d600d157bf9ec1cd0f5cf78a47348a3.tar.gz
gnu: Add perl-lwp-mediatypes.
* gnu/packages/web.scm (perl-lwp-mediatypes): New variable.
-rw-r--r--gnu/packages/web.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 0bfa784717..2ed9d5e2d0 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -150,3 +150,25 @@ used by the HTTP protocol (and then some more).")
represent \"Uniform Resource Identifier references\" as specified in RFC 2396
(and updated by RFC 2732).")
(home-page "http://search.cpan.org/~gaas/URI/")))
+
+(define-public perl-lwp-mediatypes
+ (package
+ (name "perl-lwp-mediatypes")
+ (version "6.02")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/G/GA/GAAS/LWP-MediaTypes-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0xmnblp962qy02akah30sji8bxrqcyqlff2w95l199ghql60ny8q"))))
+ (build-system perl-build-system)
+ (license (package-license perl))
+ (synopsis "Perl module to guess the media type for a file or a URL")
+ (description
+ "The LWP::MediaTypes module provides functions for handling media (also
+known as MIME) types and encodings. The mapping from file extensions to
+media types is defined by the media.types file. If the ~/.media.types file
+exists it is used instead.")
+ (home-page "http://search.cpan.org/~gaas/LWP-MediaTypes/")))