summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-09-25 00:38:04 +0200
committerLudovic Courtès <ludo@gnu.org>2013-09-25 00:39:19 +0200
commit1fa49a2c4636c0f35972c16f6bd2d28a4424b821 (patch)
tree618ded9693b8d28541667762c19921f04a902edc
parent5608847c6f4131e8f30321fdf25289efd73f8689 (diff)
downloadguix-patches-1fa49a2c4636c0f35972c16f6bd2d28a4424b821.tar
guix-patches-1fa49a2c4636c0f35972c16f6bd2d28a4424b821.tar.gz
gnu: m4: Upgrade to 1.4.17.
* gnu/packages/m4.scm (m4): Upgrade to 1.4.17. Remove 'm4-s_isdir.patch' and 'm4-gets-undeclared.patch'. * gnu/packages/patches/m4-s_isdir.patch: Remove. * gnu-system.am (dist_patch_DATA): Adjust accordingly.
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/m4.scm16
-rw-r--r--gnu/packages/patches/m4-s_isdir.patch14
3 files changed, 6 insertions, 25 deletions
diff --git a/gnu-system.am b/gnu-system.am
index e2eb043deb..304c51f6cf 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -222,7 +222,6 @@ dist_patch_DATA = \
gnu/packages/patches/libtool-skip-tests.patch \
gnu/packages/patches/m4-gets-undeclared.patch \
gnu/packages/patches/m4-readlink-EINVAL.patch \
- gnu/packages/patches/m4-s_isdir.patch \
gnu/packages/patches/make-impure-dirs.patch \
gnu/packages/patches/mcron-install.patch \
gnu/packages/patches/perl-no-sys-dirs.patch \
diff --git a/gnu/packages/m4.scm b/gnu/packages/m4.scm
index 0be1824382..17ca7c8440 100644
--- a/gnu/packages/m4.scm
+++ b/gnu/packages/m4.scm
@@ -26,14 +26,14 @@
(define-public m4
(package
(name "m4")
- (version "1.4.16")
+ (version "1.4.17")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/m4/m4-"
version ".tar.bz2"))
(sha256
(base32
- "035r7ma272j2cwni2961jp22k6bn3n9xwn3b3qbcn2yrvlghql22"))))
+ "0w0da1chh12mczxa5lnwzjk9czi3dq6gnnndbpa6w4rj76b1yklf"))))
(build-system gnu-build-system)
(arguments
;; XXX: Disable tests on those platforms with know issues.
@@ -41,10 +41,8 @@
'("x86_64-darwin"
"i686-cygwin"
"i686-sunos")))
- #:patches (list (assoc-ref %build-inputs "patch/s_isdir")
- (assoc-ref %build-inputs
- "patch/readlink-EINVAL")
- (assoc-ref %build-inputs "patch/gets"))
+ #:patches (list (assoc-ref %build-inputs
+ "patch/readlink-EINVAL"))
#:phases (alist-cons-before
'check 'pre-check
(lambda* (#:key inputs #:allow-other-keys)
@@ -57,10 +55,8 @@
(("/bin/sh")
(format #f "~a/bin/bash" bash)))))
%standard-phases)))
- (inputs `(("patch/s_isdir" ,(search-patch "m4-s_isdir.patch"))
- ("patch/readlink-EINVAL"
- ,(search-patch "m4-readlink-EINVAL.patch"))
- ("patch/gets" ,(search-patch "m4-gets-undeclared.patch"))))
+ (inputs `(("patch/readlink-EINVAL"
+ ,(search-patch "m4-readlink-EINVAL.patch"))))
(synopsis "Macro processor")
(description
"GNU M4 is an implementation of the traditional Unix macro processor. It
diff --git a/gnu/packages/patches/m4-s_isdir.patch b/gnu/packages/patches/m4-s_isdir.patch
deleted file mode 100644
index a009a4ba44..0000000000
--- a/gnu/packages/patches/m4-s_isdir.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Fails to build with glibc 2.12.1 without this patch.
-
-http://lists.gnu.org/archive/html/bug-m4/2010-05/msg00002.html
-
---- a/src/path.c
-+++ b/src/path.c
-@@ -22,6 +22,7 @@
- /* Handling of path search of included files via the builtins "include"
- and "sinclude". */
-
- #include "m4.h"
-+#include "sys/stat.h"
-
- struct includes