summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-07-14 16:58:43 +0200
committerLudovic Courtès <ludo@gnu.org>2013-07-14 16:58:43 +0200
commitffd2093440b801e449c1b69367d86a184f183a40 (patch)
tree685d81d361f6111ac85ac60f8b90922b212ac42a
parent614bdaffbf82f9c36fae407cb4e8096781ebe393 (diff)
downloadguix-patches-ffd2093440b801e449c1b69367d86a184f183a40.tar
guix-patches-ffd2093440b801e449c1b69367d86a184f183a40.tar.gz
gnu: make-bootstrap: Skip tests for the statically-linked gawk.
* gnu/packages/make-bootstrap.scm (%static-inputs)[gawk]: Add #:tests? #f.
-rw-r--r--gnu/packages/make-bootstrap.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 97362baff2..fbc7a59a03 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -153,6 +153,13 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(gawk (package (inherit gawk)
(arguments
`(#:patches (list (assoc-ref %build-inputs "patch/sh"))
+
+ ;; Starting from gawk 4.1.0, some of the tests for the
+ ;; plug-in mechanism just fail on static builds:
+ ;;
+ ;; ./fts.awk:1: error: can't open shared library `filefuncs' for reading (No such file or directory)
+ #:tests? #f
+
,@(substitute-keyword-arguments (package-arguments gawk)
((#:phases phases)
`(alist-cons-before