summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-12-18 12:09:13 +0100
committerLudovic Courtès <ludo@gnu.org>2016-12-18 12:37:26 +0100
commit8a4c98889270c163581231692fef64d9433b101f (patch)
tree17979d1fbe800141d54ddb319ed34c6dc94c798f
parent5073ecf055bc5b2d7fadef878046b15ae03652f7 (diff)
downloadguix-patches-8a4c98889270c163581231692fef64d9433b101f.tar
guix-patches-8a4c98889270c163581231692fef64d9433b101f.tar.gz
build: check-final-inputs-self-contained has an exception for 'bash:include'.
Currently 'bash:include' of the final Bash depends on bootstrap stuff. * build-aux/check-final-inputs-self-contained.scm (final-inputs): Add clause for 'bash:include'. * gnu/packages/commencement.scm (bash-final): Add FIXME comment.
-rw-r--r--build-aux/check-final-inputs-self-contained.scm7
-rw-r--r--gnu/packages/commencement.scm1
2 files changed, 7 insertions, 1 deletions
diff --git a/build-aux/check-final-inputs-self-contained.scm b/build-aux/check-final-inputs-self-contained.scm
index 255286be29..dc44c4b636 100644
--- a/build-aux/check-final-inputs-self-contained.scm
+++ b/build-aux/check-final-inputs-self-contained.scm
@@ -37,12 +37,17 @@
(let ((drv (package-derivation store package system)))
;; Libc's 'debug' output refers to gcc-cross-boot0, but it's
;; hard to avoid, so we tolerate it. This should be the
- ;; only exception.
+ ;; only exception. Likewise, 'bash:include' depends on
+ ;; bootstrap-binaries via its 'Makefile.inc' (FIXME).
(filter-map (match-lambda
(("debug" . directory)
(if (string=? "glibc" (package-name package))
#f
directory))
+ (("include" . directory)
+ (if (string=? "bash" (package-name package))
+ #f
+ directory))
((_ . directory) directory))
(derivation->output-paths drv)))))
%final-inputs))
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 2431babcad..c7aa59e9a2 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -783,6 +783,7 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
(define bash-final
;; Link with `-static-libgcc' to make sure we don't retain a reference
;; to the bootstrap GCC.
+ ;; FIXME: This depends on 'bootstrap-binaries' via Makefile.in.
(package-with-bootstrap-guile
(package-with-explicit-inputs (static-libgcc-package bash)
%boot3-inputs