summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-08-01 11:24:25 +0200
committerLudovic Courtès <ludo@gnu.org>2016-08-01 11:26:33 +0200
commit683a4a34cd4a565cbdb0b46a326e30795657814c (patch)
treecccb704be8cfc2464b164a992329bd2faf40e3f3
parent4e8efc15fb9082fb80726a2a37c4e6ebb13552fa (diff)
downloadguix-patches-683a4a34cd4a565cbdb0b46a326e30795657814c.tar
guix-patches-683a4a34cd4a565cbdb0b46a326e30795657814c.tar.gz
gnu: openssh: Add dependency on xauth.
Partly fixes <http://bugs.gnu.org/23317>. Reported by Danny Milosavljevic <dannym@scratchpost.org>. * gnu/packages/ssh.scm (openssh)[inputs]: Add XAUTH.
-rw-r--r--gnu/packages/ssh.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index a669ccfc9b..6953bad58a 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -143,7 +143,8 @@ a server that supports the SSH-2 protocol.")
(build-system gnu-build-system)
(inputs `(("groff" ,groff)
("openssl" ,openssl)
- ("zlib" ,zlib)))
+ ("zlib" ,zlib)
+ ("xauth" ,xauth))) ;for 'ssh -X' and 'ssh -Y'
(arguments
`(#:test-target "tests"
#:phases