summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-16 23:25:03 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-16 23:40:02 +0100
commitd0414883074475a2b0ea85f27fb792bfccea9e89 (patch)
treef52cc6c35c73462a7b277a6af1bc15abb8ae2899
parent874e6874284126c8836894b0f46dce8f6e803641 (diff)
downloadguix-patches-d0414883074475a2b0ea85f27fb792bfccea9e89.tar
guix-patches-d0414883074475a2b0ea85f27fb792bfccea9e89.tar.gz
distro: Add Expat.
* distro/packages/xml.scm: New file. * Makefile.am (MODULES): Add it.
-rw-r--r--Makefile.am1
-rw-r--r--distro/packages/xml.scm44
2 files changed, 45 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 713dd8fe14..beba7dffa4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -112,6 +112,7 @@ MODULES = \
distro/packages/time.scm \
distro/packages/wget.scm \
distro/packages/which.scm \
+ distro/packages/xml.scm \
distro/packages/zile.scm
diff --git a/distro/packages/xml.scm b/distro/packages/xml.scm
new file mode 100644
index 0000000000..5962e35d86
--- /dev/null
+++ b/distro/packages/xml.scm
@@ -0,0 +1,44 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (distro packages xml)
+ #:use-module ((guix licenses)
+ #:renamer (symbol-prefix-proc 'license:))
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu))
+
+(define-public expat
+ (package
+ (name "expat")
+ (version "2.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/expat/expat/"
+ version "/expat-" version ".tar.gz"))
+ (sha256
+ (base32
+ "11pblz61zyxh68s5pdcbhc30ha1b2vfjd83aiwfg4vc15x3hadw2"))))
+ (build-system gnu-build-system)
+ (home-page "http://www.libexpat.org/")
+ (synopsis "A stream-oriented XML parser library written in C")
+ (description
+ "Expat is an XML parser library written in C. It is a
+stream-oriented parser in which an application registers handlers for
+things the parser might find in the XML document (like start tags).")
+ (license license:expat)))