summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-16 23:50:51 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-16 23:50:51 +0100
commit183c9a89a38342a0d4f2dc1564140dcee57270fc (patch)
treea1951722390bc6594eb5165b10f2eb323f9f38e9
parentd0414883074475a2b0ea85f27fb792bfccea9e89 (diff)
downloadguix-patches-183c9a89a38342a0d4f2dc1564140dcee57270fc.tar
guix-patches-183c9a89a38342a0d4f2dc1564140dcee57270fc.tar.gz
distro: gdb: Add dependency on Expat and Python.
* distro/packages/gdb.scm (gdb): Add Expat and Python as inputs.
-rw-r--r--distro/packages/gdb.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/distro/packages/gdb.scm b/distro/packages/gdb.scm
index 2402820b33..4540c04099 100644
--- a/distro/packages/gdb.scm
+++ b/distro/packages/gdb.scm
@@ -22,7 +22,9 @@
#:use-module (distro packages dejagnu)
#:use-module (distro packages texinfo)
#:use-module (distro packages multiprecision)
- #:use-module (guix licenses)
+ #:use-module (distro packages xml)
+ #:use-module (distro packages python)
+ #:use-module ((guix licenses) #:select (gpl3+))
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu))
@@ -46,12 +48,12 @@
(patch-makefile-SHELL "gdb/gdbserver/Makefile.in"))
%standard-phases)))
(inputs
- `(;; ("expat" ,expat)
+ `(("expat" ,expat)
("mpfr" ,mpfr)
("gmp" ,gmp)
("readline" ,readline)
("ncurses" ,ncurses)
- ;; ("python" ,python) ; TODO: Add dependency on Python.
+ ("python" ,python)
("texinfo" ,texinfo)
("dejagnu" ,dejagnu)))
(home-page "http://www.gnu.org/software/gdb/")