summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-06-15 10:04:38 +0200
committerLudovic Courtès <ludo@gnu.org>2012-06-15 10:04:38 +0200
commit48e8333d91ea64ccbc6e694393783498f1aa5d4b (patch)
treeecc5a34c3293f917caccbec65541ab410ecd291c
parent1273d44ac73fe7e33b51809d2d3000fde7c4d4e3 (diff)
downloadguix-patches-48e8333d91ea64ccbc6e694393783498f1aa5d4b.tar
guix-patches-48e8333d91ea64ccbc6e694393783498f1aa5d4b.tar.gz
build: Provide the right include path when building modules.
* Makefile.am (.scm.go): Add missing `-L $(top_srcdir)'.
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 5cc49a73fb..0a51552054 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -48,7 +48,8 @@ CLEANFILES = $(GOBJECTS) *.log
$(MKDIR_P) `dirname "$@"`
GUILE_AUTO_COMPILE=0 \
GUILE_LOAD_COMPILED_PATH="$(top_builddir):$$GUILE_LOAD_COMPILED_PATH" \
- $(GUILD) compile -Wformat -Wunbound-variable -Warity-mismatch \
+ $(GUILD) compile -L "$(top_srcdir)" \
+ -Wformat -Wunbound-variable -Warity-mismatch \
-o "$@" "$<"
SUFFIXES = .go