summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFeng Shu <tumashu@163.com>2022-03-21 19:29:10 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-01-29 09:03:16 +0800
commit29ec1a4bb74e6374491699806068f4422d6e3041 (patch)
treed2434debd3fffad943246cff98244ef6372194cc
parent6d13a13a1a6c923a810680e08e250edbb5f624aa (diff)
downloadguix-patches-29ec1a4bb74e6374491699806068f4422d6e3041.tar
guix-patches-29ec1a4bb74e6374491699806068f4422d6e3041.tar.gz
gnu: Add thunar-archive-plugin.
* gnu/packages/xfce.scm (thunar-archive-plugin): New variable. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/xfce.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 25af3a1ae5..8159010361 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -781,6 +781,27 @@ digital camera, it will automatically spawn your preferred photo application
and import the new pictures from your camera.")
(license gpl2+)))
+(define-public thunar-archive-plugin
+ (package
+ (name "thunar-archive-plugin")
+ (version "0.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://archive.xfce.org/src/thunar-plugins/"
+ name "/" (version-major+minor version)
+ "/" name "-" version ".tar.bz2"))
+ (sha256
+ (base32 "1ykg6qj65l5wywpbiiabidjxzvrhv6q4v63jxb6mlai8b2iqijlf"))))
+ (build-system gnu-build-system)
+ (native-inputs (list pkg-config intltool))
+ (inputs (list exo thunar gtk+))
+ (home-page "https://www.xfce.org/")
+ (synopsis "Archive plugin for Thunar file manager")
+ (description "The Thunar Archive Plugin allows you to create and extract
+archive files using the file context menus in the Thunar file manager.")
+ (license gpl2+)))
+
(define-public xfwm4
(package
(name "xfwm4")