summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-06-23 11:00:16 +0200
committerChristopher Baines <mail@cbaines.net>2024-07-11 10:25:21 +0100
commit97d86b9c7e655a9fb157f025c0cee8ddeb258ee1 (patch)
treef02a369bc8fe3ae330f2de839e05112b9e4158b6
parent42dbd9b591424dba3d87607ba55c06cb36b261b3 (diff)
downloadguix-patches-97d86b9c7e655a9fb157f025c0cee8ddeb258ee1.tar
guix-patches-97d86b9c7e655a9fb157f025c0cee8ddeb258ee1.tar.gz
gnu: texlive-amstex: Create missing symlink.
* gnu/packages/tex.scm (texlive-amstex)[arguments]<#:phases>: Create missing symlink. Change-Id: Ibd71612febb0e7768e43f432bd3e71af82e39634
-rw-r--r--gnu/packages/tex.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 0deb83d64d..c55773bf9d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3015,7 +3015,17 @@ create a bibliography.")
"01yh10g2wwa58q151aqg246bsclks25qvd8axc1v799v37wlgqn3"))))
(outputs '("out" "doc"))
(build-system texlive-build-system)
- (arguments (list #:create-formats #~(list "amstex")))
+ (arguments
+ (list #:create-formats #~(list "amstex")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'symlink-binaries
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((pdftex (search-input-file inputs "bin/pdftex"))
+ (bin (string-append #$output "/bin")))
+ (mkdir-p bin)
+ (with-directory-excursion bin
+ (symlink pdftex "amstex"))))))))
(propagated-inputs
(list texlive-amsfonts
texlive-cm