summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-06-23 11:21:18 +0200
committerChristopher Baines <mail@cbaines.net>2024-07-11 10:25:22 +0100
commit7a0e35ee1d9ddefdd43f477f7021ea63577ab3e1 (patch)
tree41e73ba8020d8f9ec9501eca0911a3179059e7d2
parent443197997b09e185c4e39853be0eaf00ecc64836 (diff)
downloadguix-patches-7a0e35ee1d9ddefdd43f477f7021ea63577ab3e1.tar
guix-patches-7a0e35ee1d9ddefdd43f477f7021ea63577ab3e1.tar.gz
gnu: texlive-optex: Create missing symlink.
* gnu/packages/tex.scm (texlive-optex)[arguments]<#:phases>: Create missing symlink. Change-Id: I5b86e979ca3c6ce2aa8e6481596389dd83acb4ca
-rw-r--r--gnu/packages/tex.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2bd98ab337..813a9ccad3 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -71830,7 +71830,17 @@ and back-ends. It also ensures compatibility with the @code{media9} and
"0bcrj9wrimcd2pxrcfk7x3vkhxzij4422l19a8j4h299lkq3pbx0"))))
(outputs '("out" "doc"))
(build-system texlive-build-system)
- (arguments (list #:create-formats #~(list "optex")))
+ (arguments
+ (list #:create-formats #~(list "optex")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'symlink-binaries
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((luatex (search-input-file inputs "bin/luatex"))
+ (bin (string-append #$output "/bin")))
+ (mkdir-p bin)
+ (with-directory-excursion bin
+ (symlink luatex "optex"))))))))
(propagated-inputs
(list texlive-amsfonts
texlive-cm