summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-06-26 10:18:47 +0200
committerChristopher Baines <mail@cbaines.net>2024-07-11 10:25:24 +0100
commit0a8dd5ab8f96d10fd291db226bed85739decfc54 (patch)
treecff5e720eff91a3f15454441520b99de63b5feb1
parented5c40b79f224cd877568b4d8eb7141a2ce7fe10 (diff)
downloadguix-patches-0a8dd5ab8f96d10fd291db226bed85739decfc54.tar
guix-patches-0a8dd5ab8f96d10fd291db226bed85739decfc54.tar.gz
gnu: texlive-extract: Skip build.
* gnu/packages/tex.scm (texlive-extract)[arguments]<#:phases>: Remove BUILD phase. [native-inputs]: Add TEXLIVE-ETOOLBOX. Change-Id: Iaf1fb8368a85619aa00c0241f6098c9bef4a8fea
-rw-r--r--gnu/packages/tex.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6d8cd5c7b2..bc9c3a4104 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -102437,10 +102437,17 @@ LaTeX, to generate a nice solution book.")
(outputs '("out" "doc"))
(properties '((updater-extra-native-inputs "texlive-updmap.cfg")))
(build-system texlive-build-system)
- (arguments (list #:tex-format "latex"))
+ (arguments
+ (list #:tex-format "latex"
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; FIXME: Build fails with "LaTeX socket Error: Sockets can
+ ;; only be declared at top-level!". Skip build.
+ (delete 'build))))
(native-inputs
(list (texlive-updmap.cfg
- (list texlive-float
+ (list texlive-etoolbox
+ texlive-float
texlive-fourier
texlive-hypdoc
texlive-listings