summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-06-22 00:16:42 -0300
committerVinicius Monego <monego@posteo.net>2024-07-05 23:04:15 -0300
commiteae4786c118e358c117f4877926a55286ba75c5b (patch)
tree712ed6f9436f12ba1f2ffa2478abfc22d1a2a19a
parentb79a10f28fe948c721114d590bc33ed0ddf92190 (diff)
downloadguix-patches-eae4786c118e358c117f4877926a55286ba75c5b.tar
guix-patches-eae4786c118e358c117f4877926a55286ba75c5b.tar.gz
gnu: python-cartopy: Update to 0.23.0.
* gnu/packages/geo.scm (python-cartopy): Update to 0.23.0. [arguments]<#:test-flags>: Skip more network tests. Change-Id: Idbd2b3c52cba0fb58e78171df330581bf83ecbdf
-rw-r--r--gnu/packages/geo.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 1146939408..9923ca9195 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1489,13 +1489,13 @@ surface (i.e., gridding) with a hint of machine learning.")
(define-public python-cartopy
(package
(name "python-cartopy")
- (version "0.22.0")
+ (version "0.23.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Cartopy" version))
(sha256
- (base32 "0jdv92az0b7qxdvalh29kasw3knsl570cz7q3vql67ck400zj05k"))))
+ (base32 "0xknmq73pvkm3k718zrsx8p4r83dbskwqna9v4qvmwh1ayrkf7r3"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -1506,8 +1506,16 @@ surface (i.e., gridding) with a hint of machine learning.")
"-m" "not natural_earth and not network"
"-k"
(string-append
- ;; This one too but it's not marked as such.
- "not test_gridliner_labels_bbox_style"
+ ;; These ones too but are not marked as such.
+ "not test_feature_artist_draw"
+ " and not test_feature_artist_draw_facecolor_list"
+ " and not test_feature_artist_draw_cmap"
+ " and not test_feature_artist_draw_styled_feature"
+ " and not test_feature_artist_draw_styler"
+ " and not test_gridliner_constrained_adjust_datalim"
+ " and not test_gridliner_remove"
+ " and not test_gridliner_title_adjust"
+ " and not test_gridliner_labels_bbox_style"
;; Accuracy problems
" and not test_single_spole"
" and not test_single_npole"