summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDariqq <dariqq@posteo.net>2024-07-06 07:29:18 +0000
committerGuix Patches Tester <>2024-07-06 10:29:05 +0200
commit8ffe13e9ca7dcdded73c9ba5bb1b0ae31b341809 (patch)
tree24bc58a80646c0a65bb38a273a3e2c9ebf396d2a
parent334cb61facfebccd9d557a16592efd718ce8a453 (diff)
downloadguix-patches-8ffe13e9ca7dcdded73c9ba5bb1b0ae31b341809.tar
guix-patches-8ffe13e9ca7dcdded73c9ba5bb1b0ae31b341809.tar.gz
gnu: fastfetch: Add more configure flags.
Most importantly the dependencies are now linked dynamically to avoid writing out a LD_LIBRARY_PATH wrapper. Also build the tests and skip installing the license file. Additionally provide custom paths to pci-ids and amdgpu-ids. * gnu/packages/admin.scm (fastfetch) (arguments): Move above inputs. [#:configure-flags]: Add -DBUILD_TESTS=ON, -DINSTALL_LICENSE=OFF, -DBINARY_LINK_TYPE=dynamic and set -DCUSTOM_PCI_IDS_PATH and -DCUSTOM_AMDGPU_IDS_PATH. [#:tests]: Remove as now there are tests available. [inputs]: Add hwdata and libdrm for the custom paths. Change-Id: I9f86b49f0a116bcee91ca15b6e77cfbb3867e290
-rw-r--r--gnu/packages/admin.scm17
1 files changed, 14 insertions, 3 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index a9651b49d0..e97fe76a5a 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -4280,18 +4280,29 @@ information tool.")
(snippet '(begin
(delete-file-recursively "src/3rdparty")))))
(build-system cmake-build-system)
+ (arguments
+ (list
+ #:configure-flags #~(list "-DENABLE_SYSTEM_YYJSON=YES"
+ "-DBINARY_LINK_TYPE=dynamic"
+ "-DBUILD_TESTS=ON"
+ "-DINSTALL_LICENSE=OFF"
+ (string-append "-DCUSTOM_PCI_IDS_PATH="
+ #$(this-package-input "hwdata")
+ "/share/hwdata/pci.ids")
+ (string-append "-DCUSTOM_AMDGPU_IDS_PATH="
+ #$(this-package-input "libdrm")
+ "share/libdrm/amdgpu.ids"))))
(inputs (list dbus
glib
+ hwdata
imagemagick
+ libdrm
libxcb
mesa
wayland
yyjson
zlib)) ;for imagemagick and an #ifdef
(native-inputs (list pkg-config))
- (arguments
- (list #:tests? #f ; no test target
- #:configure-flags #~(list "-DENABLE_SYSTEM_YYJSON=YES")))
(home-page "https://github.com/fastfetch-cli/fastfetch")
(synopsis "Display system information in a stylized manner")
(description