summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-01 21:46:19 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-11 19:15:09 +0100
commit5a33a71e678eeea5b27a3912f4dd7160528618fa (patch)
treede78c199b72795ba083a4880329272cbc8d61039
parent2eb7cc2677272fe099e5aeef7a75c381776aaf0e (diff)
downloadguix-patches-5a33a71e678eeea5b27a3912f4dd7160528618fa.tar
guix-patches-5a33a71e678eeea5b27a3912f4dd7160528618fa.tar.gz
gnu: python-dolfin-adjoint: Fix indentation.
* gnu/packages/simulation.scm (python-dolfin-adjoint): Fix indentation. Change-Id: I457639a98f1ae49d43042e557352d390afc9419d
-rw-r--r--gnu/packages/simulation.scm48
1 files changed, 24 insertions, 24 deletions
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index 4fa2e93d81..ab86e1d792 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -1180,29 +1180,29 @@ command-line utility for mesh optimisation.")
(name "python-dolfin-adjoint")
(version "2019.1.0")
(source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/dolfin-adjoint/pyadjoint")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0xhy76a5f33hz94wc9g2mc5qmwkxfccbbc6yxl7psm130afp8lhn"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; One of the migration tests attempts to call openmpi
- ;; recursively and fails. See
- ;; https://bitbucket.org/mpi4py/mpi4py/issues/95. Run the
- ;; test sequentially instead.
- (with-directory-excursion "tests/migration/optimal_control_mms"
- (substitute* "test_optimal_control_mms.py"
- (("\\\"mpirun\\\", \\\"-n\\\", \\\"2\\\", ") "")))
- ;; Result files are regenerated in the check phase.
- (delete-file-recursively
- "tests/migration/viscoelasticity/test-results")
- #t))))
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dolfin-adjoint/pyadjoint")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0xhy76a5f33hz94wc9g2mc5qmwkxfccbbc6yxl7psm130afp8lhn"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; One of the migration tests attempts to call openmpi
+ ;; recursively and fails. See
+ ;; https://bitbucket.org/mpi4py/mpi4py/issues/95. Run the
+ ;; test sequentially instead.
+ (with-directory-excursion "tests/migration/optimal_control_mms"
+ (substitute* "test_optimal_control_mms.py"
+ (("\\\"mpirun\\\", \\\"-n\\\", \\\"2\\\", ") "")))
+ ;; Result files are regenerated in the check phase.
+ (delete-file-recursively
+ "tests/migration/viscoelasticity/test-results")
+ #t))))
(build-system python-build-system)
(inputs
(list fenics openmpi pybind11))
@@ -1219,7 +1219,7 @@ command-line utility for mesh optimisation.")
`(#:phases
(modify-phases %standard-phases
(add-after 'build 'mpi-setup
- ,%openmpi-setup)
+ ,%openmpi-setup)
(add-after 'install 'install-doc
(lambda* (#:key outputs #:allow-other-keys)
(let* ((doc (string-append (assoc-ref outputs "out")