summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Trofimov <sarg@sarg.org.ru>2024-07-01 22:53:13 +0200
committerAndrew Tropin <andrew@trop.in>2024-07-02 12:33:00 +0400
commite209437ca2fc2740d9fa934b65831272380b8fb8 (patch)
tree94d8a3c164f8c363541964dee26b6fdc92d02668
parent5f1e4e4c0242af6bcba656aedf8b49afbe7247b7 (diff)
downloadguix-patches-e209437ca2fc2740d9fa934b65831272380b8fb8.tar
guix-patches-e209437ca2fc2740d9fa934b65831272380b8fb8.tar.gz
gnu: Add tgs2png.
* gnu/packages/animation.scm (tgs2png): New variable. Signed-off-by: Andrew Tropin <andrew@trop.in>
-rw-r--r--gnu/packages/animation.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/animation.scm b/gnu/packages/animation.scm
index 3bcf1cc8f0..869f0d2c00 100644
--- a/gnu/packages/animation.scm
+++ b/gnu/packages/animation.scm
@@ -468,6 +468,37 @@ lets you create traditional hand-drawn animations (cartoons) using both bitmap
and vector graphics.")
(license license:gpl2)))
+(define-public tgs2png
+ (let ((commit "25c15b7c2ca3b1a580a383d9d3cb13bf8531d04a")
+ (revision "0"))
+ (package
+ (name "tgs2png")
+ (version (git-version "0.3.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zevlg/tgs2png")
+ (commit commit)))
+ (sha256
+ (base32 "0camvzapkfvr9v0nkk96n26rdmw0g8wbpv41i5l03j6bzdgm4myl"))
+ (file-name (git-file-name "tgs2png" version))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (delete-file-recursively "rlottie")
+ #t))))
+ (arguments '(#:tests? #f))
+ (build-system cmake-build-system)
+ (inputs
+ (list rlottie libpng))
+ (native-inputs
+ (list pkg-config))
+ (home-page "https://github.com/zevlg/tgs2png")
+ (synopsis "Convert Telegram's animated stickers to PNG")
+ (description "Convert Telegram's animated stickers in TGS format into series of PNG images.")
+ (license license:gpl3+))))
+
(define-public swftools
;; Last release of swftools was 0.9.2 on 2012-04-21 - it is really old and
;; does not compile with what's available in guix, master on the other hand works.