summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAda Stevenson <adanskana@gmail.com>2024-07-01 14:35:13 +0800
committerjgart <jgart@dismail.de>2024-07-01 02:08:20 -0500
commitba6460900f052759fe82e4ceb606d25e19f02884 (patch)
tree5a7ba681603beeb825836ec2eb418a1439418878
parentb61493721a20d128b399a21af6d1b22c227d0fb2 (diff)
downloadguix-patches-ba6460900f052759fe82e4ceb606d25e19f02884.tar
guix-patches-ba6460900f052759fe82e4ceb606d25e19f02884.tar.gz
gnu: glances: Update to 4.1.1.
* gnu/packages/python-xyz.scm (glances): Update to 4.1.1. [source]: Update PyPI uri. [propagated-inputs]: Remove python-future and python-ujson and add python-orjson. Change-Id: I4c9a1a59916b922d136e8ceec5984b26aa4f3496 Signed-off-by: jgart <jgart@dismail.de>
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ff507e1855..36f75b4b40 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22801,13 +22801,13 @@ numbers, real numbers, mixed types and more, and comes with a shell command
(define-public glances
(package
(name "glances")
- (version "3.4.0.3")
+ (version "4.1.1")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "Glances" version))
+ (uri (pypi-uri "glances" version))
(sha256
- (base32 "0pf8hxbgwkhv8l5frg61b073vscz5a7bz1al7xhn36fvh10xbcg7"))
+ (base32 "10yjwbmwv2x4x1n3hr1631m8l6l9w8fa7rnvfz1vmzkjs199ihib"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -22821,7 +22821,7 @@ numbers, real numbers, mixed types and more, and comes with a shell command
#t))))
(build-system python-build-system)
(propagated-inputs
- (list python-defusedxml python-future python-packaging python-psutil python-ujson))
+ (list python-defusedxml python-orjson python-packaging python-psutil))
(home-page "https://github.com/nicolargo/glances")
(synopsis "Cross-platform curses-based monitoring tool")
(description