summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-06-23 11:20:09 +0200
committerChristopher Baines <mail@cbaines.net>2024-06-29 12:13:21 +0100
commitd0d0598bc63b83f17e64f2d601c818647b015626 (patch)
tree63d3bf711bdfab9f8dd419732ccd8f28c175341c
parent1ebf770dd9f3377f65783365f1b89779d20e9149 (diff)
downloadguix-patches-d0d0598bc63b83f17e64f2d601c818647b015626.tar
guix-patches-d0d0598bc63b83f17e64f2d601c818647b015626.tar.gz
gnu: texlive-mltex: Create missing symlinks.
* gnu/packages/tex.scm (texlive-mltex)[arguments]<#:phases>: Create missing symlinks. Change-Id: I05c7aa88aee42f01fea96bd36a173fa494d54d6d
-rw-r--r--gnu/packages/tex.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d9fbf514fc..2bd98ab337 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -27062,7 +27062,18 @@ avoids the spindliness of most other Type 1 versions of Computer Modern.")
"1ip0q5kqj6bg4jkginzljknbrd74ss4iky2gvlmf8nnrq06n89my"))))
(outputs '("out" "doc"))
(build-system texlive-build-system)
- (arguments (list #:create-formats #~(list "mllatex" "mltex")))
+ (arguments
+ (list #:create-formats #~(list "mllatex" "mltex")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'symlink-binaries
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((pdftex (search-input-file inputs "bin/pdftex"))
+ (bin (string-append #$output "/bin")))
+ (mkdir-p bin)
+ (with-directory-excursion bin
+ (symlink pdftex "mllatex")
+ (symlink pdftex "mltex"))))))))
(propagated-inputs
(list texlive-atbegshi
texlive-atveryend