summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-19 22:38:00 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-29 09:37:40 +0100
commit6d520b8c0c8ac562f8275cbb8f77bf6ebacd2444 (patch)
tree24c5ef23a8194de88582b2243cdc4689163a4964
parentcaf5cfaa0dc0bacd45e0406ddc30bca0e4e4eece (diff)
downloadguix-patches-6d520b8c0c8ac562f8275cbb8f77bf6ebacd2444.tar
guix-patches-6d520b8c0c8ac562f8275cbb8f77bf6ebacd2444.tar.gz
gnu: docker: Apply "-trimpath" flag.
* gnu/packages/docker.scm (docker) [arguments]: <#:phases>: Remove 'remove-go-references phase. Set BUILDFLAGS=-trimpath to replace 'remove-go-references phase in 'build phase. Change-Id: Iada1a8764808d26e476ca8ca87a23061834f78be
-rw-r--r--gnu/packages/docker.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index b18de182fe..c033486c6a 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -547,6 +547,7 @@ runcexecutor/executor.go"
;; Our LD doesn't like the statically linked relocatable things
;; that go produces, so install the dynamic version of
;; dockerd instead.
+ (setenv "BUILDFLAGS" "-trimpath")
(invoke "hack/make.sh" "dynbinary")))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
@@ -570,9 +571,7 @@ runcexecutor/executor.go"
(install-file "bundles/dynbinary-daemon/dockerd" out-bin)
(install-file (string-append "bundles/dynbinary-daemon/dockerd-"
(getenv "VERSION"))
- out-bin))))
- (add-after 'install 'remove-go-references
- (assoc-ref go:%standard-phases 'remove-go-references)))))
+ out-bin)))))))
(inputs
(list btrfs-progs
containerd ; for containerd-shim