summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-26 21:30:53 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-27 00:34:27 +0100
commit9fb7946a232919844a600a3633a8944043085d3d (patch)
treeb32c3b8e127afe292787d5c06837f82cc38373e1
parentbd908af0c619cb1b74afeeb07839d7af08de9d91 (diff)
downloadguix-patches-9fb7946a232919844a600a3633a8944043085d3d.tar
guix-patches-9fb7946a232919844a600a3633a8944043085d3d.tar.gz
gnu: go-github-com-petermattis-goid: Move to golang-check.
* gnu/packages/syncthing.scm (go-github-com-petermattis-goid): Move from here ... * gnu/packages/golang-check.scm: ... to here. Change-Id: I68182d8131afdcb346076d4f1e69ccf680b48cdb
-rw-r--r--gnu/packages/golang-check.scm26
-rw-r--r--gnu/packages/syncthing.scm24
2 files changed, 26 insertions, 24 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 1caf1e6069..502b09f7ab 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -732,6 +732,32 @@ Go application.")
original value once the test has been run.")
(license license:expat)))
+(define-public go-github-com-petermattis-goid
+ (let ((commit "b0b1615b78e5ee59739545bb38426383b2cda4c9")
+ (revision "1"))
+ (package
+ (name "go-github-com-petermattis-goid")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/petermattis/goid")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ghfxn045r0bbn2vszw897lxzmhnm4k59aypjvpxl0pbzsw9ab2c"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/petermattis/goid"))
+ (home-page "https://github.com/petermattis/goid")
+ (synopsis "Identify the running goroutine")
+ (description
+ "This package offers a method of programmatically retrieving the
+current goroutine's ID.")
+ (license license:asl2.0))))
+
(define-public go-github-com-stretchr-testify
(package
(name "go-github-com-stretchr-testify")
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 7269e91ec0..5e7e8f96db 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -509,30 +509,6 @@ hashes.")
(home-page "https://github.com/chmduquesne/rollinghash")
(license expat))))
-(define-public go-github-com-petermattis-goid
- (let ((commit "b0b1615b78e5ee59739545bb38426383b2cda4c9")
- (revision "1"))
- (package
- (name "go-github-com-petermattis-goid")
- (version (git-version "0.0.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/petermattis/goid")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0ghfxn045r0bbn2vszw897lxzmhnm4k59aypjvpxl0pbzsw9ab2c"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/petermattis/goid"))
- (synopsis "Identify the running goroutine")
- (description "This package offers a method of programmatically retrieving
-the current goroutine's ID.")
- (home-page "https://github.com/petermattis/goid")
- (license asl2.0))))
-
(define-public go-github-com-syncthing-notify
(let ((commit "69c7a957d3e261f9744f46b3dd4d608d8480ad90")
(revision "5"))