summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-27 00:06:26 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-27 00:35:37 +0100
commit8db567d19db63c6f6092126b89d8ac2a37bdc000 (patch)
tree5aa71fb12dacc84fbfff845057c24faf616cd23c
parent3244c6ca88d7416641248456fb8cecafeec3f9b1 (diff)
downloadguix-patches-8db567d19db63c6f6092126b89d8ac2a37bdc000.tar
guix-patches-8db567d19db63c6f6092126b89d8ac2a37bdc000.tar.gz
gnu: go-github-com-go-ldap-ldap: Enable tests.
* gnu/packages/golang-web.scm (go-github-com-go-ldap-ldap): Enable tests. [native-inputs]: Add go-github-com-stretchr-testify. Change-Id: I6c3090abac883f87e75534a60e0c9e5ff518887d
-rw-r--r--gnu/packages/golang-web.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 421468a6b8..69c97cf12a 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -805,8 +805,18 @@ Encryption, JSON Web Signature, and JSON Web Token standards.")
(build-system go-build-system)
(arguments
(list
- #:tests? #f ; test suite requires internet access
- #:import-path "github.com/go-ldap/ldap/v3"))
+ #:import-path "github.com/go-ldap/ldap/v3"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-failing-tests
+ (lambda* (#:key import-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" import-path)
+ (for-each delete-file
+ ;; FAIL <...> LDAP Result Code 200 "Network Error":
+ ;; dial tcp: lookup ldap.itd.umich.edu on <...>
+ (list "ldap_test.go"))))))))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
(propagated-inputs
(list go-github-com-azure-go-ntlmssp
go-github-com-go-asn1-ber-asn1-ber