summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilko Meyer <w@wmeyer.eu>2024-06-24 00:01:35 +0200
committerjgart <jgart@dismail.de>2024-06-24 08:46:06 -0500
commitd6211a9a71b4c5affb9a7e96b6d954ed5a4588cc (patch)
tree4dd4f6c2733c45c9f86baeec94425722025a722a
parentadf841fe3aeb2e3bdf2532a42251e5eba9664dcf (diff)
downloadguix-patches-d6211a9a71b4c5affb9a7e96b6d954ed5a4588cc.tar
guix-patches-d6211a9a71b4c5affb9a7e96b6d954ed5a4588cc.tar.gz
gnu: python-geoip2: Update to 4.8.0.
* gnu/packages/geo.scm (python-geoip2): Update to 4.8.0. [build-system]: Change to pyproject-build-system. [inputs]: Add python-aiohttp. Change-Id: Ie5f4a6f99a8cb1bef562c6d2401391f6467a715d Signed-off-by: jgart <jgart@dismail.de>
-rw-r--r--gnu/packages/geo.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 0fad220f1c..1146939408 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -2398,19 +2398,21 @@ MaxMind DB files.")
(define-public python-geoip2
(package
(name "python-geoip2")
- (version "2.9.0")
+ (version "4.8.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "geoip2" version))
(sha256
(base32
- "1w7cay5q6zawjzivqbwz5cqx1qbdjw6kbriccb7l46p7b39fkzzp"))))
- (build-system python-build-system)
+ "0ddcm6a0f5xr66r84hpn6jr6b7hl77axb0d41qj285ylny0c376x"))))
+ (build-system pyproject-build-system)
(arguments
`(#:tests? #f)) ;; Tests require a copy of the maxmind database
(inputs
- (list python-maxminddb python-requests))
+ (list python-maxminddb
+ python-requests
+ python-aiohttp))
(home-page "https://www.maxmind.com/")
(synopsis "MaxMind GeoIP2 API")
(description "Provides an API for the GeoIP2 web services and databases.