summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-06 16:28:50 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-06 23:30:33 +0100
commit4c51c895c0d2ccabaa11b7bd688a5a8751987266 (patch)
treedd3f74371c81c11513bfbdbd76521d3485b86788
parentdfece5197c01c2f8ad8ccc37c1419f9fb0a89771 (diff)
downloadguix-patches-4c51c895c0d2ccabaa11b7bd688a5a8751987266.tar
guix-patches-4c51c895c0d2ccabaa11b7bd688a5a8751987266.tar.gz
gnu: python-tweakwcs: Sort alphabetically.
* gnu/packages/astronomy.scm (python-tweakwcs): Sort alphabetically. Change-Id: Ifbc33e0d4605e8cae6ebcf18a90cfbd60c3a393b
-rw-r--r--gnu/packages/astronomy.scm70
1 files changed, 35 insertions, 35 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 38d9ed0723..6cdd20b92f 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -4492,41 +4492,6 @@ PYSYNPHOT, utilizing Astropy and covering the non-instrument specific portions
of the old packages.")
(license license:bsd-3)))
-(define-public python-tweakwcs
- (package
- (name "python-tweakwcs")
- (version "0.8.7")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "tweakwcs" version))
- (sha256
- (base32 "0cch4z5zmmi1s02n1wdwss8p7qhrzyiajkaik0gga510kgdsvx48"))))
- (build-system pyproject-build-system)
- (propagated-inputs
- (list python-astropy
- python-gwcs
- python-numpy
- python-packaging
- python-spherical-geometry
- python-stsci-imagestats
- python-stsci-stimage))
- (native-inputs
- (list python-codecov
- python-pytest
- python-pytest-cov
- python-scipy
- python-setuptools-scm))
- (home-page "https://tweakwcs.readthedocs.io/en/latest/")
- (synopsis
- "Algorithms for matching and aligning catalogs and for tweaking the WCS")
- (description
- "@code{tweakwcs} is a package that provides core algorithms for computing
-and applying corrections to @code{WCS} objects such as to minimize mismatch
-between image and reference catalogs. Currently only aligning images with
-@code{FITS WCS} and @code{JWST gWCS} are supported.")
- (license license:bsd-3)))
-
(define-public python-asdf
(package
(name "python-asdf")
@@ -5163,6 +5128,41 @@ astronomical images, especially when there is no WCS information available.")
orbit around the Earth.")
(license license:expat)))
+(define-public python-tweakwcs
+ (package
+ (name "python-tweakwcs")
+ (version "0.8.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "tweakwcs" version))
+ (sha256
+ (base32 "0cch4z5zmmi1s02n1wdwss8p7qhrzyiajkaik0gga510kgdsvx48"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs
+ (list python-astropy
+ python-gwcs
+ python-numpy
+ python-packaging
+ python-spherical-geometry
+ python-stsci-imagestats
+ python-stsci-stimage))
+ (native-inputs
+ (list python-codecov
+ python-pytest
+ python-pytest-cov
+ python-scipy
+ python-setuptools-scm))
+ (home-page "https://tweakwcs.readthedocs.io/en/latest/")
+ (synopsis
+ "Algorithms for matching and aligning catalogs and for tweaking the WCS")
+ (description
+ "@code{tweakwcs} is a package that provides core algorithms for computing
+and applying corrections to @code{WCS} objects such as to minimize mismatch
+between image and reference catalogs. Currently only aligning images with
+@code{FITS WCS} and @code{JWST gWCS} are supported.")
+ (license license:bsd-3)))
+
(define-public python-viresclient
(package
(name "python-viresclient")