summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-05-30 18:23:02 +0000
committerGuix Patches Tester <>2024-07-03 04:17:36 +0200
commite67a71ba1150ed8089f371d5086860e451df308d (patch)
treeb2d102c2727792b027c8877dfe590c2a03ab6e71
parent4595afe66a79b90a8823d4765dfda171875dc027 (diff)
downloadguix-patches-e67a71ba1150ed8089f371d5086860e451df308d.tar
guix-patches-e67a71ba1150ed8089f371d5086860e451df308d.tar.gz
gnu: vigra: Update to 1.11.2.
* gnu/packages/image.scm (vigra): Update to 1.11.2. [inputs]: Use package labels. Add imath. Replace openexr-2 by openexr. [native-inputs]: Use package labels. [arguments]<#:configure-flags>: Unset "-DCMAKE_CXX_FLAGS". Change-Id: I4dd538ca386c6486ed57cde61337118c2c32d99d
-rw-r--r--gnu/packages/image.scm137
1 files changed, 59 insertions, 78 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 5f73a6c3f6..ab3a13c603 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -1331,87 +1331,68 @@ graphics image formats like PNG, BMP, JPEG, TIFF and others.")
(home-page "https://freeimage.sourceforge.io/")))
(define-public vigra
- (let ((commit "9b514fa00a136f5fd81bb57ee9f6293c333ffc1f")
- (revision "0"))
- (package
- (name "vigra")
- (version (git-version "1.11.1" revision commit))
- (source
- (origin
- ;; The last release is 1.11.1, from 2017. It's becoming more and more
- ;; difficult to build this old release, and the upstream developers
- ;; suggest on their home page to build from the Git repo, saying "It is
- ;; generally safe to use the 'master' branch of the development snapshot,
- ;; as we avoid uploading untested or incompatible changes to this branch."
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/ukoethe/vigra")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256 (base32
- "1vzlypviala109imwxkp46lqhhxszf79ypfb8wxg6z7g02j7mm73"))))
- (build-system cmake-build-system)
- (inputs
- `(("boost" ,boost)
- ("fftw" ,fftw)
- ("fftwf" ,fftwf)
- ("hdf5" ,hdf5)
- ("ilmbase" ,ilmbase) ; propagated by openexr, but needed explicitly
- ; to create a configure-flag
- ("libjpeg" ,libjpeg-turbo)
- ("libpng" ,libpng)
- ("libtiff" ,libtiff)
- ("openexr" ,openexr-2)
- ("python" ,python-wrapper)
- ;("python-numpy" ,python-numpy)
- ("zlib" ,zlib)))
- (native-inputs
- `(("doxygen" ,doxygen)
- ("python-nose" ,python-nose)
- ("sphinx" ,python-sphinx)))
- (arguments
- `(#:test-target "check"
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'disable-broken-tests
- (lambda _
- ;; See https://github.com/ukoethe/vigra/issues/432
- (substitute* "test/fourier/CMakeLists.txt"
- (("VIGRA_ADD_TEST.*") ""))
- ;; This test fails with Numpy 1.15:
- ;; <https://github.com/ukoethe/vigra/issues/436>.
- (substitute* "vigranumpy/test/CMakeLists.txt"
- (("test1\\.py") ""))
- #t)))
- #:configure-flags
- (list "-Wno-dev" ; suppress developer mode with lots of warnings
- (string-append "-DVIGRANUMPY_INSTALL_DIR="
- (assoc-ref %outputs "out")
- "/lib/python"
- ,(version-major+minor (package-version python))
- "/site-packages")
- ;; Vigranumpy isn't compatible with numpy >= 1.20.
- "-DWITH_VIGRANUMPY=0"
- ;; OpenEXR is not enabled by default.
- "-DWITH_OPENEXR=1"
- ;; Fix rounding error on 32-bit machines
- "-DCMAKE_C_FLAGS=-ffloat-store"
- ;; The header files of ilmbase are not found when included
- ;; by the header files of openexr, and an explicit flag
- ;; needs to be set.
- (string-append "-DCMAKE_CXX_FLAGS=-I"
- (assoc-ref %build-inputs "ilmbase")
- "/include/OpenEXR"
- " -ffloat-store"))))
- (synopsis "Computer vision library")
- (description
- "VIGRA stands for Vision with Generic Algorithms. It is an image
+ (package
+ (name "vigra")
+ (version "1.11.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ukoethe/vigra")
+ (commit "Version-1-11-2")))
+ (file-name (git-file-name name version))
+ (sha256 (base32
+ "12ywzz8c6p1cmmr3b849yhvmbi1kmqz2ag82qpj41hy8lis6gaf4"))))
+ (build-system cmake-build-system)
+ (inputs
+ (list boost
+ fftw
+ fftwwf
+ hdf5
+ imath
+ libjpeg-turbo
+ libpng
+ libtiff
+ openexr
+ python-wrapper))
+ (native-inputs
+ (list doxygen python-nose python-sphinx))
+ (arguments
+ `(#:test-target "check"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'disable-broken-tests
+ (lambda _
+ ;; See https://github.com/ukoethe/vigra/issues/432
+ (substitute* "test/fourier/CMakeLists.txt"
+ (("VIGRA_ADD_TEST.*") ""))
+ ;; This test fails with Numpy 1.15:
+ ;; <https://github.com/ukoethe/vigra/issues/436>.
+ (substitute* "vigranumpy/test/CMakeLists.txt"
+ (("test1\\.py") ""))
+ #t)))
+ #:configure-flags
+ (list "-Wno-dev" ; suppress developer mode with lots of warnings
+ (string-append "-DVIGRANUMPY_INSTALL_DIR="
+ (assoc-ref %outputs "out")
+ "/lib/python"
+ ,(version-major+minor (package-version python))
+ "/site-packages")
+ ;; Vigranumpy isn't compatible with numpy >= 1.20.
+ "-DWITH_VIGRANUMPY=0"
+ ;; OpenEXR is not enabled by default.
+ "-DWITH_OPENEXR=1"
+ ;; Fix rounding error on 32-bit machines
+ "-DCMAKE_C_FLAGS=-ffloat-store")))
+ (synopsis "Computer vision library")
+ (description
+ "VIGRA stands for Vision with Generic Algorithms. It is an image
processing and analysis library that puts its main emphasis on customizable
algorithms and data structures. It is particularly strong for
multi-dimensional image processing.")
- (license license:expat)
- (home-page "https://ukoethe.github.io/vigra/")
- (properties '((max-silent-time . 7200)))))) ;2 hours, to avoid timing out
+ (license license:expat)
+ (home-page "https://ukoethe.github.io/vigra/")
+ (properties '((max-silent-time . 7200))))) ;2 hours, to avoid timing out
(define-public vigra-c
(let* ((commit "66ff4fa5a7d4a77415caa676a45c2c6ea16562e7")