summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2024-05-06 10:59:45 +0200
committerLudovic Courtès <ludo@gnu.org>2024-06-11 12:12:38 +0200
commiteddc3d6dfdd39f4e7eda6e1884293ed2da55ef7e (patch)
treed36efe982dc6fd13883cf35bcdc171bd83cfb80c
parent49b5588b29efe9d36533779514f3db5470ec5d36 (diff)
downloadguix-patches-eddc3d6dfdd39f4e7eda6e1884293ed2da55ef7e.tar
guix-patches-eddc3d6dfdd39f4e7eda6e1884293ed2da55ef7e.tar.gz
gnu: glibc: Remove unneeded workaround configure flags for Hurd.
* gnu/packages/base.scm (%glibc/hurd-configure-flags): Remove variable. (glibc): Stop using %glibc/hurd-configure-flags. Change-Id: I5cbdf8956a826d1eb25c449d4bc8a16d87dc8b80
-rw-r--r--gnu/packages/base.scm14
1 files changed, 1 insertions, 13 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index c82081cf8e..2188be071f 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -768,17 +768,6 @@ the store.")
(home-page "https://www.gnu.org/software/guix//")
(license gpl3+)))
-(define-public %glibc/hurd-configure-flags
- ;; 'configure' in glibc 2.35 omits to pass '-ffreestanding' when detecting
- ;; Mach headers. This is fixed in glibc commits
- ;; 8b8c768e3c701ed1993789bb46acb8a12c7a93df and
- ;; 7685630b98ca2a3f5de86eadf130993e6cf998a0; as a workaround, bypass those
- ;; tests.
- '("ac_cv_header_mach_mach_types_defs=yes"
- "ac_cv_header_mach_mach_types_h=yes"
- "ac_cv_header_mach_machine_ndr_def_h=no"
- "libc_cv_mach_task_creation_time=yes"))
-
(define-public glibc
;; This is the GNU C Library, used on GNU/Linux and GNU/Hurd. Prior to
;; version 2.28, GNU/Hurd used a different glibc branch.
@@ -877,8 +866,7 @@ the store.")
;; On GNU/Hurd we get discarded-qualifiers warnings for
;; 'device_write_inband' among other things. Ignore them.
,@(if (target-hurd?)
- `("--disable-werror"
- ,@%glibc/hurd-configure-flags)
+ `("--disable-werror")
'()))
#:tests? #f ; XXX