summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2024-05-05 19:51:03 +0200
committerLudovic Courtès <ludo@gnu.org>2024-06-11 12:12:38 +0200
commit49b5588b29efe9d36533779514f3db5470ec5d36 (patch)
tree1ce282ecb663831857e4fd7c89abe33978c105d9
parent253463daa38d237d92f876ab6003efc2ace1f564 (diff)
downloadguix-patches-49b5588b29efe9d36533779514f3db5470ec5d36.tar
guix-patches-49b5588b29efe9d36533779514f3db5470ec5d36.tar.gz
gnu: redis: Skip OOM score test.
Since "daemon: Sacrifice builders on OOM." the default OOM score has changed to 1000, which effictively render this test impossible to pass. * gnu/packages/databases.scm (redis): Skip OOM score test. Change-Id: I92ff49425faa755cd4d0a22a33bf8b1fea03d25a
-rw-r--r--gnu/packages/databases.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index b877d9ef92..36b3117297 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -2574,6 +2574,11 @@ similar to BerkeleyDB, LevelDB, etc.")
;; "background AOF rewrite to finish", perhaps because dead
;; processes persist as zombies in the build environment.
(("unit/aofrw") "")
+ ;; The OOM score tests try to raise the current OOM score, but
+ ;; our build environment already sets it for all children to
+ ;; the highest possible one (1000). We can't lower it because
+ ;; we don't have CAP_SYS_RESOURCE.
+ (("unit/oom-score-adj") "")
(("integration/aof(-multi-part)?") "")
(("integration/failover") "")
(("integration/replication-4") "")