summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-05-23 00:44:47 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-05-23 00:45:43 +0100
commit3ebb39eb42bd091d693ccbfeda48d78c3ffd5c3c (patch)
tree61ad0863b92f91fc65f88314ad01f5e082c493fe
parenta3318b4edead56f4c15cf7b879c208260bb9d5c0 (diff)
downloadguix-patches-3ebb39eb42bd091d693ccbfeda48d78c3ffd5c3c.tar
guix-patches-3ebb39eb42bd091d693ccbfeda48d78c3ffd5c3c.tar.gz
gnu: go-github-com-syndtr-goleveldb-leveldb: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-syndtr-goleveldb-leveldb): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: Ib457abe33612b371c33985c6b3b0e9372221e37d
-rw-r--r--gnu/packages/golang-xyz.scm30
-rw-r--r--gnu/packages/golang.scm30
2 files changed, 30 insertions, 30 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index d4e04c9ebc..0b869b39e3 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3358,6 +3358,36 @@ well as a program to generate applications and command files.")
(home-page "https://github.com/stathat/go")
(license license:expat))))
+(define-public go-github-com-syndtr-goleveldb-leveldb
+ (package
+ (name "go-github-com-syndtr-goleveldb-leveldb")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/syndtr/goleveldb")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "042k0gbzs5waqpxmd7nv5h93mlva861s66c3s9gfg1fym5dx4vmd"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:go go-1.21
+ #:import-path "github.com/syndtr/goleveldb/leveldb"
+ #:unpack-path "github.com/syndtr/goleveldb"))
+ (propagated-inputs
+ (list go-github-com-onsi-gomega
+ go-github-com-onsi-ginkgo
+ go-github-com-golang-snappy))
+ (home-page "https://github.com/syndtr/goleveldb")
+ (synopsis "LevelDB implementation in Go")
+ (description
+ "This package provides a Go implementation of the LevelDB key/value
+storage system.")
+ (license license:bsd-2)))
+
(define-public go-github-com-tklauser-go-sysconf
(package
(name "go-github-com-tklauser-go-sysconf")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 64b79564e6..ab41508103 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5425,36 +5425,6 @@ representation suitable for computing diffs.")
golang's database/sql package.")
(license license:mpl2.0)))
-(define-public go-github-com-syndtr-goleveldb-leveldb
- (package
- (name "go-github-com-syndtr-goleveldb-leveldb")
- (version "1.0.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/syndtr/goleveldb")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "042k0gbzs5waqpxmd7nv5h93mlva861s66c3s9gfg1fym5dx4vmd"))))
- (build-system go-build-system)
- (arguments
- (list
- #:go go-1.21
- #:import-path "github.com/syndtr/goleveldb/leveldb"
- #:unpack-path "github.com/syndtr/goleveldb"))
- (propagated-inputs
- (list go-github-com-onsi-gomega
- go-github-com-onsi-ginkgo
- go-github-com-golang-snappy))
- (home-page "https://github.com/syndtr/goleveldb")
- (synopsis "LevelDB implementation in Go")
- (description
- "This package provides a Go implementation of the LevelDB key/value
-storage system.")
- (license license:bsd-2)))
-
(define-public go-github-com-lucasb-eyer-go-colorful
(package
(name "go-github-com-lucasb-eyer-go-colorful")