summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-05-17 15:24:05 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-05-22 21:31:52 +0100
commit8f0b5e35f377131da499f596dfacba97acd27bf3 (patch)
treed2107bd15b28884f81263811efd6968c100a2e5e
parentee86a504e9223b1ef861d830ecf3aaf03cc1364d (diff)
downloadguix-patches-8f0b5e35f377131da499f596dfacba97acd27bf3.tar
guix-patches-8f0b5e35f377131da499f596dfacba97acd27bf3.tar.gz
gnu: Add python-augeas.
* gnu/packages/python-xyz.scm (python-augeas): New variable. Change-Id: I46d409debfbc358f0ff27c505fba089ceab4e195 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/augeas.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/augeas.scm b/gnu/packages/augeas.scm
index f643b1573e..fa46520991 100644
--- a/gnu/packages/augeas.scm
+++ b/gnu/packages/augeas.scm
@@ -25,9 +25,13 @@
#:use-module (guix gexp)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix utils)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system pyproject)
#:use-module (gnu packages)
+ #:use-module (gnu packages check)
+ #:use-module (gnu packages libffi)
#:use-module (gnu packages readline)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages xml))
@@ -66,3 +70,28 @@ that have been made to the tree; it does as little modeling of configurations
as possible, and focuses exclusivley on transforming the tree-oriented syntax
of its public API to the myriad syntaxes of individual configuration files.")
(license license:lgpl2.1+)))
+
+(define-public python-augeas
+ (package
+ (name "python-augeas")
+ (version "1.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hercules-team/python-augeas")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1l17gl23f5naram1jaab7gjr9bhjdj97fd9sydvs7cmpns91rbrf"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-pytest pkg-config))
+ (propagated-inputs
+ (list python-cffi))
+ (inputs
+ (list augeas libxml2))
+ (home-page "https://github.com/hercules-team/python-augeas")
+ (synopsis "Python bindings for Augeas")
+ (description "Pure Python bindings for @url{https://augeas.net, Augeas}.")
+ (license license:lgpl2.1+)))