summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-05-19 13:16:07 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-05-19 16:10:51 +0300
commit85fa9458a13a4d774db7031791e24807bf2da76b (patch)
treef87a21c392bc93a92dfa37038c5c35d31b5d2621
parent58614c9b4bba93773adbc502df202ae980b01eae (diff)
downloadguix-patches-85fa9458a13a4d774db7031791e24807bf2da76b.tar
guix-patches-85fa9458a13a4d774db7031791e24807bf2da76b.tar.gz
gnu: python-numba: Adjust test suite on several architectures.
* gnu/packages/python-xyz.scm (python-numba)[arguments]: Adjust the 'disable-failing-tests phase to skip some additional tests on aarch64-linux and powerpc64le-linux. Also when building for armhf-linux accept a wider range of python platforms as being part of armhf-linux. Change-Id: If9edf9282684931a2a4cdcfed692ed3da1d4ec6e
-rw-r--r--gnu/packages/python-xyz.scm32
1 files changed, 31 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ddc697f71b..61167d3db5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27536,7 +27536,37 @@ validation testing and application logic.")
;; This one test fails because a deprecation warning is printed.
(substitute* "numba/tests/test_import.py"
(("def test_no_accidental_warnings")
- "def disabled_test_no_accidental_warnings"))))
+ "def disabled_test_no_accidental_warnings"))
+ ;; Some tests timeout or crash on some architectures.
+ ,@(cond
+ ((target-aarch64?)
+ `((substitute* "numba/tests/test_sets.py"
+ (("def test_add_discard")
+ "def disabled_test_add_discard")
+ (("def test_isdisjoint")
+ "def disabled_test_isdisjoint")
+ (("def test_issubset")
+ "def disabled_test_issubset")
+ (("def test_issuperset")
+ "def disabled_test_issuperset")
+ (("def test_remove_error")
+ "def disabled_test_remove_error"))))
+ ((target-ppc64le?)
+ `((substitute* "numba/tests/test_mathlib.py"
+ (("def test_ldexp")
+ "def disabled_test_ldexp"))))
+ ((target-arm32?)
+ ;; Armhf emulation on aarch64 using armv8 machines returns
+ ;; 'armv8l' from platform.machine() and won't skip some tests.
+ ;; Fix borrowed from an upstream bug report:
+ ;; https://github.com/numba/numba/issues/6345#issuecomment-764993001
+ `((substitute* '("numba/tests/support.py"
+ "numba/tests/test_dispatcher.py")
+ (("platform\\.machine\\(\\) == 'armv7l'")
+ (string-append
+ "platform.machine().startswith('armv') and "
+ "int(platform.machine()[len('armv'):-1]) >= 7")))))
+ (#t '()))))
(replace 'check
(lambda* (#:key tests? inputs outputs #:allow-other-keys)
(when tests?