summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Volf <~@wolfsden.cz>2024-05-10 00:23:10 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-05-21 22:44:05 +0100
commite89bfb919e5b73ad917770c94327309254e82e85 (patch)
treeabb9712df709282efc324337fc2272d360ef1794
parent2bfdc768d7e0d6cde9d90997830bee93333307c1 (diff)
downloadguix-patches-e89bfb919e5b73ad917770c94327309254e82e85.tar
guix-patches-e89bfb919e5b73ad917770c94327309254e82e85.tar.gz
gnu: Add podman-compose.
* gnu/packages/containers.scm (podman-compose): New variable. Change-Id: Ieb5ee4b6e82464599a17ec950be8a7dbb2efa842 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/containers.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
index 5f86c512b6..29b390758b 100644
--- a/gnu/packages/containers.scm
+++ b/gnu/packages/containers.scm
@@ -34,6 +34,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
#:use-module (guix build-system meson)
+ #:use-module (guix build-system pyproject)
#:use-module (guix utils)
#:use-module (gnu packages admin)
#:use-module (gnu packages autotools)
@@ -49,6 +50,8 @@
#:use-module (gnu packages python)
#:use-module (gnu packages networking)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages python-check)
#:use-module (gnu packages rust-apps)
#:use-module (gnu packages selinux)
#:use-module (gnu packages version-control)
@@ -540,6 +543,34 @@ The @code{machine} subcommand is not supported due to gvproxy not being
packaged.")
(license license:asl2.0)))
+(define-public podman-compose
+ (package
+ (name "podman-compose")
+ (version "1.0.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/containers/podman-compose")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "11dwpifkm20vyi6r3fgmiiqc01mpm4r8l0p5gfh0bawi2gklrhsf"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags #~(list "pytests")))
+ (native-inputs
+ (list python-pytest))
+ (propagated-inputs
+ (list python-dotenv python-pyyaml))
+ (home-page "https://github.com/containers/podman-compose")
+ (synopsis "Script to run docker-compose.yml using podman")
+ (description "This package provides an implementation of
+@url{https://compose-spec.io/, Compose Spec} for @code{podman} focused on
+being rootless and not requiring any daemon to be running.")
+ (license license:gpl2)))
+
(define-public buildah
(package
(name "buildah")