summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilke Schwiedop <wilke.schwiedop@agfa.com>2024-05-10 00:23:09 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-05-21 22:33:57 +0100
commit2bfdc768d7e0d6cde9d90997830bee93333307c1 (patch)
tree73e723afe47f3674d6422f5aa0bd5a1580ee565d
parent5bea6482e68ebb3695f4372c5f3df7920807c531 (diff)
downloadguix-patches-2bfdc768d7e0d6cde9d90997830bee93333307c1.tar
guix-patches-2bfdc768d7e0d6cde9d90997830bee93333307c1.tar.gz
gnu: Add catatonit.
* gnu/packages/containers.scm (catatonit): New variable. Change-Id: Ib6948bde8204426a8cb008982cb7cc9302f9e6d6 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/containers.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
index d005b2b9c8..5f86c512b6 100644
--- a/gnu/packages/containers.scm
+++ b/gnu/packages/containers.scm
@@ -411,6 +411,34 @@ It can be used with QEMU, Hyperkit, Hyper-V and User-Mode Linux.
The binary is called @command{gvproxy}.")
(license license:asl2.0)))
+(define-public catatonit
+ (package
+ (name "catatonit")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/openSUSE/catatonit/releases/download/v"
+ version "/catatonit.tar.xz"))
+ (sha256
+ (base32 "141b5lypgqib546zmldi4kqzpqfd6vvqddqqkfaz3w11fjsc4hwq"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list autoconf automake libtool))
+ (home-page "https://github.com/openSUSE/catatonit")
+ (synopsis "Container init")
+ (description
+ "Catatonit is a simple container init tool developed as a rewrite of
+@url{https://github.com/cyphar/initrs, initrs} in C due to the need for static
+compilation of Rust binaries with @code{musl}. Inspired by other container
+inits like @url{https://github.com/krallin/tini, tini} and
+@url{https://github.com/Yelp/dumb-init, dumb-init}, catatonit focuses on
+correct signal handling, utilizing @code{signalfd(2)} for improved stability.
+Its main purpose is to support the key usage by @code{docker-init}:
+@code{/dev/init} – <your program>, with minimal additional features planned.")
+ (license license:gpl2+)))
+
(define-public podman
(package
(name "podman")