summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2024-05-08 03:02:51 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-05-08 15:07:04 +0200
commit7da082bee9babe99389fa464fac84df27c456ef2 (patch)
tree3380c43ac84cd42bbc1c8d88fd867db9fa5c8c59
parent3de6e38a14cf2b31aeef81a0af0f0a3730378f29 (diff)
downloadguix-patches-7da082bee9babe99389fa464fac84df27c456ef2.tar
guix-patches-7da082bee9babe99389fa464fac84df27c456ef2.tar.gz
gnu: Add r-mlr3viz.
* gnu/packages/cran.scm (r-mlr3viz): New variable. Change-Id: Iedca442886ebeb09d26cfa44290192c582aeeef3
-rw-r--r--gnu/packages/cran.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index fd0e2cee64..f575dfb310 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -38219,6 +38219,34 @@ machine learning algorithms. The search spaces are from scientific articles and
work for a wide range of data sets.")
(license license:lgpl3)))
+(define-public r-mlr3viz
+ (package
+ (name "r-mlr3viz")
+ (version "0.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "mlr3viz" version))
+ (sha256
+ (base32 "1m2f54yqhk1bd4c30vd1z509yblz6y4i8qkwhg73aa1sflnsycvf"))))
+ (properties `((upstream-name . "mlr3viz")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-checkmate
+ r-data-table
+ r-ggplot2
+ r-mlr3misc
+ r-scales
+ r-viridis))
+ (home-page "https://mlr3viz.mlr-org.com")
+ (synopsis "Visualizations for mlr3")
+ (description
+ "This package offers features plots for mlr3 objects such as tasks, learners,
+predictions, benchmark results, tuning instances and filters via the
+@code{autoplot()} generic of ggplot2. The mlr3viz package draws plots with
+the viridis color palette and applies the minimal theme. Visualizations include
+barplots, boxplots, histograms, ROC curves, and precision-recall curves.")
+ (license license:lgpl3)))
+
(define-public r-paradox
(package
(name "r-paradox")