summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2023-09-16 23:36:06 -0300
committerVinicius Monego <monego@posteo.net>2024-05-11 15:35:36 -0300
commit6f595eca59c00412b80657495d30ed110d9166c0 (patch)
treed5f80b29ee7fd90a9ce925ef3a58964ec31205a0
parent43e790f4c95564063d8c1c7b6e866d96da2203ad (diff)
downloadguix-patches-6f595eca59c00412b80657495d30ed110d9166c0.tar
guix-patches-6f595eca59c00412b80657495d30ed110d9166c0.tar.gz
gnu: Add python-botorch.
* gnu/packages/machine-learning.scm (python-botorch): New variable. Change-Id: Iaa67584a3b72ff07bc8bbb92cfa60fde1d9d7647
-rw-r--r--gnu/packages/machine-learning.scm48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 7ff8c098b1..253e2ddef2 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -5127,6 +5127,54 @@ linear algebra routines needed for structured matrices (or operators).")
"GPyTorch is a Gaussian process library implemented using PyTorch.")
(license license:expat)))
+(define-public python-botorch
+ (package
+ (name "python-botorch")
+ (version "0.11.0")
+ (source (origin
+ (method git-fetch) ;no tests in PyPI
+ (uri (git-reference
+ (url "https://github.com/pytorch/botorch")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1b10xydxl6x5y5kzvf0561da5374zh00nwq7fcmdw6mb1axipgbq"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'lo-version
+ (lambda _
+ (substitute* "requirements.txt"
+ ;; Linear Operator 0.5.2 is a bug-fix release.
+ (("linear_operator==0.5.1")
+ "linear_operator==0.5.2")
+ ;; We have PyTorch 1.13.1, but the reported
+ ;; version is 1.13.0a0+gitunknown.
+ (("torch>=1.13.1") "torch"))))
+ (add-before 'build 'pretend-version
+ ;; The version string is usually derived via setuptools-scm,
+ ;; but without the git metadata available, the version string
+ ;; is set to '0.0.0'.
+ (lambda _
+ (setenv "SETUPTOOLS_SCM_PRETEND_VERSION"
+ #$(package-version this-package)))))))
+ (propagated-inputs (list python-gpytorch
+ python-linear-operator
+ python-multipledispatch
+ python-pyro-ppl
+ python-pytorch
+ python-scipy))
+ (native-inputs (list python-pytest
+ python-pytest-cov
+ python-setuptools-scm))
+ (home-page "https://botorch.org")
+ (synopsis "Bayesian Optimization in PyTorch")
+ (description
+ "BoTorch is a library for Bayesian Optimization built on PyTorch.")
+ (license license:expat)))
+
(define-public vosk-api
(let* ((openfst openfst-for-vosk)
(kaldi kaldi-for-vosk))