summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilko Meyer <w@wmeyer.eu>2024-05-01 00:27:28 +0200
committerGuix Patches Tester <>2024-05-01 01:45:10 +0200
commit0408e481c5cb8ccf19581c86d28552fd800b8173 (patch)
tree823d9b3483a8539beeab8783a88a4abcefb89683
parent09c9f750f4eac325ad5405a9ad8847fcf230239e (diff)
downloadguix-patches-0408e481c5cb8ccf19581c86d28552fd800b8173.tar
guix-patches-0408e481c5cb8ccf19581c86d28552fd800b8173.tar.gz
gnu: rust-tokio-postgres-0.7: Update to 0.7.10.
* gnu/packages/crates-io.scm (rust-tokio-postgres-0.7): Update to 0.7.10. [cargo-inputs]: Update dependencies. Change-Id: Icc4a4fd956d29d49c86cbeec6e2e32266c1e32e4
-rw-r--r--gnu/packages/crates-io.scm17
1 files changed, 10 insertions, 7 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index c701e57af6..3c030ad9a8 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -71806,7 +71806,7 @@ OpenSSL.")
(define-public rust-tokio-postgres-0.7
(package
(name "rust-tokio-postgres")
- (version "0.7.2")
+ (version "0.7.10")
(source
(origin
(method url-fetch)
@@ -71815,7 +71815,7 @@ OpenSSL.")
(string-append name "-" version ".tar.gz"))
(sha256
(base32
- "12rb390i3af7zb0z2idhaf6l2m6snypwdiwjw84rmyz4qy1i6ard"))))
+ "1f7m927fsinxwya36q7psk1xv2r3dqmvg324ww52c86r695j8h6k"))))
(build-system cargo-build-system)
(arguments
`(#:tests? #f ;require postgresql
@@ -71824,17 +71824,20 @@ OpenSSL.")
("rust-byteorder" ,rust-byteorder-1)
("rust-bytes" ,rust-bytes-1)
("rust-fallible-iterator" ,rust-fallible-iterator-0.2)
- ("rust-futures" ,rust-futures-0.3)
+ ("rust-futures-channel" ,rust-futures-channel-0.3)
+ ("rust-futures-util" ,rust-futures-util-0.3)
("rust-log" ,rust-log-0.4)
- ("rust-parking-lot" ,rust-parking-lot-0.11)
+ ("rust-parking-lot" ,rust-parking-lot-0.12)
("rust-percent-encoding" ,rust-percent-encoding-2)
- ("rust-phf" ,rust-phf-0.8)
+ ("rust-phf" ,rust-phf-0.11)
("rust-pin-project-lite" ,rust-pin-project-lite-0.2)
("rust-postgres-protocol" ,rust-postgres-protocol-0.6)
("rust-postgres-types" ,rust-postgres-types-0.2)
- ("rust-socket2" ,rust-socket2-0.4)
+ ("rust-rand" ,rust-rand-0.8)
+ ("rust-socket2" ,rust-socket2-0.5)
("rust-tokio" ,rust-tokio-1)
- ("rust-tokio-util" ,rust-tokio-util-0.6))
+ ("rust-tokio-util" ,rust-tokio-util-0.7)
+ ("rust-whoami" ,rust-whoami-1))
#:cargo-development-inputs
(("rust-bit-vec" ,rust-bit-vec-0.6)
("rust-chrono" ,rust-chrono-0.4)