summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-05-15 11:06:26 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-05-15 15:42:42 +0300
commitc9d4a1c42e159e824e82b9f8f6652a6f52a4dcb5 (patch)
treed270350e55b54ddf0135407546136e6fa0cf0686
parent84a53f3fa422d913507cf0d1fe6f017c59a7d159 (diff)
downloadguix-patches-c9d4a1c42e159e824e82b9f8f6652a6f52a4dcb5.tar
guix-patches-c9d4a1c42e159e824e82b9f8f6652a6f52a4dcb5.tar.gz
gnu: the-butterfly-effect: Fix build.
* gnu/packages/games.scm (the-butterfly-effect)[build-system]: Switch to the cmake-build-system. [arguments]: Don't delete the 'configure phase. Remove custom 'install phase. Add a phase to set some cmake variables and one to disable the translations. [native-inputs]: Remove cmake-minimal. Change-Id: I8f654b1e0c3231dda87ea41c150cc85661541cda
-rw-r--r--gnu/packages/games.scm27
1 files changed, 12 insertions, 15 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 1a2c2236c8..30a4d425f3 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -19,7 +19,7 @@
;;; Copyright © 2016 Albin Söderqvist <albin@fripost.org>
;;; Copyright © 2016, 2017, 2018, 2019, 2020 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
-;;; Copyright © 2016-2021, 2023 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016-2021, 2023, 2024 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2016 Steve Webber <webber.sl@gmail.com>
;;; Copyright © 2017 Adonay "adfeno" Felipe Nogueira <https://libreplanet.org/wiki/User:Adfeno> <adfeno@hyperbola.info>
@@ -7884,22 +7884,20 @@ making Yamagi Quake II one of the most solid Quake II implementations available.
(sha256
(base32
"1ag2cp346f9bz9qy6za6q54id44d2ypvkyhvnjha14qzzapwaysj"))))
- (build-system gnu-build-system)
+ (build-system cmake-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
- (delete 'configure)
- ;; There is no "install" phase. By default, tbe is installed
- ;; in the build directory. Provide our own installation.
- (replace 'install
+ (add-after 'unpack 'set-cmake-install-prefix
(lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin"))
- (share (string-append out "/share")))
- (install-file "usr/games/tbe" bin)
- (mkdir-p share)
- (copy-recursively "usr/share" share)
- #t))))
+ (substitute* "CMakeLists.txt"
+ (("/usr") (assoc-ref outputs "out"))
+ (("TBE_BIN_DIR games") "TBE_BIN_DIR bin"))))
+ (add-after 'unpack 'disable-translations
+ ;; TODO: Re-enable translations when they no longer fail to build.
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ ((".*i18n.*") "")))))
;; Test suite requires a running Xorg server. Even when
;; provided, it fails with "D-Bus library appears to be
;; incorrectly set up; failed to read machine uuid: Failed to
@@ -7909,8 +7907,7 @@ making Yamagi Quake II one of the most solid Quake II implementations available.
(inputs
(list qtbase-5 qtsvg-5))
(native-inputs
- `(("cmake" ,cmake-minimal)
- ("gettext-minimal" ,gettext-minimal)
+ `(("gettext-minimal" ,gettext-minimal)
("qttools-5" ,qttools-5)))
(synopsis "Realistic physics puzzle game")
(description "The Butterfly Effect (tbe) is a game that uses