summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHerman Rimm <herman@rimm.ee>2024-04-27 14:35:22 +0200
committerGuix Patches Tester <>2024-04-27 16:03:15 +0200
commitec0c09bd8d24611d2e0b69c4f03e25aa34240de9 (patch)
tree7648a1879fc5c41722de5226101671e7982b4928
parent21fb2a70b7e7ab5a718c4d88e7448311d1001944 (diff)
downloadguix-patches-ec0c09bd8d24611d2e0b69c4f03e25aa34240de9.tar
guix-patches-ec0c09bd8d24611d2e0b69c4f03e25aa34240de9.tar.gz
gnu: Place rust-juniper-codegen-0.14 in alphabetical order.
* gnu/packages/crates-io.scm (rust-juniper-codegen-0.14): Move variable. Change-Id: I7f2530c9e9f38413707e4a44364009b65d1069c0
-rw-r--r--gnu/packages/crates-io.scm54
1 files changed, 27 insertions, 27 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index e33ae2832a..b72c1a497a 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -36138,33 +36138,6 @@ allocation per spawned future, whereas the futures Threadpool uses std
concurrency primitives and multiple allocations.")
(license (list license:expat license:asl2.0))))
-(define-public rust-juniper-codegen-0.14
- (package
- (name "rust-juniper-codegen")
- (version "0.14.2")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "juniper_codegen" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "06ym8568k9p75kvnfc4ywqbkzaa4ib6gngx9vpbsjwg9v0sg42nl"))))
- (build-system cargo-build-system)
- (arguments
- `(#:tests? #false ;FIXME: fail due to unresolved import
- #:cargo-inputs
- (("rust-proc-macro2" ,rust-proc-macro2-1)
- ("rust-quote" ,rust-quote-1)
- ("rust-syn" ,rust-syn-1))
- #:cargo-development-inputs
- (("rust-juniper" ,rust-juniper-0.14))))
- (home-page "https://github.com/graphql-rust/juniper")
- (synopsis "Internal custom derive trait for Juniper GraphQL")
- (description
- "This package provides an internal custom derive trait for Juniper
-GraphQL.")
- (license license:bsd-2)))
-
(define-public rust-juniper-0.14
(package
(name "rust-juniper")
@@ -36205,6 +36178,33 @@ frameworks, including embedded Graphiql and GraphQL Playground for easy
debugging.")
(license license:bsd-2)))
+(define-public rust-juniper-codegen-0.14
+ (package
+ (name "rust-juniper-codegen")
+ (version "0.14.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "juniper_codegen" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "06ym8568k9p75kvnfc4ywqbkzaa4ib6gngx9vpbsjwg9v0sg42nl"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:tests? #false ;FIXME: fail due to unresolved import
+ #:cargo-inputs
+ (("rust-proc-macro2" ,rust-proc-macro2-1)
+ ("rust-quote" ,rust-quote-1)
+ ("rust-syn" ,rust-syn-1))
+ #:cargo-development-inputs
+ (("rust-juniper" ,rust-juniper-0.14))))
+ (home-page "https://github.com/graphql-rust/juniper")
+ (synopsis "Internal custom derive trait for Juniper GraphQL")
+ (description
+ "This package provides an internal custom derive trait for Juniper
+GraphQL.")
+ (license license:bsd-2)))
+
(define-public rust-k9-0.12
(package
(name "rust-k9")