summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHerman Rimm <herman@rimm.ee>2024-04-27 14:35:14 +0200
committerGuix Patches Tester <>2024-04-27 16:03:00 +0200
commit85d42396fef8912b3481d93e9647724ab1dbd6af (patch)
tree4d0491297fac1874b4ee0bf02f9f50961ab634ec
parentaafe30040331d980eb357dd5560d68ea962d7651 (diff)
downloadguix-patches-85d42396fef8912b3481d93e9647724ab1dbd6af.tar
guix-patches-85d42396fef8912b3481d93e9647724ab1dbd6af.tar.gz
gnu: Place rust-local-ip-address-0.4 in alphabetical order.
* gnu/packages/crates-io.scm (rust-local-ip-address-0.4): Move variable. Change-Id: Ia687d844c8a2114a02ae159603e23f1dd8cbccfd
-rw-r--r--gnu/packages/crates-io.scm52
1 files changed, 26 insertions, 26 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 5fd7bbec4b..6d5b29451f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -39271,6 +39271,32 @@ can also be used outside of a proc-macro context.")
futures-aware, FIFO queue.")
(license (list license:expat license:asl2.0))))
+(define-public rust-local-ip-address-0.4
+ (package
+ (name "rust-local-ip-address")
+ (version "0.4.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "local-ip-address" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1xc88i6v43rx5f5im0zadd8nl3k7wvf2lv351q20d05h5w4pzawy"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:tests? #f ; Integration test with local IP address.
+ #:cargo-inputs (("rust-libc" ,rust-libc-0.2)
+ ("rust-neli" ,rust-neli-0.5)
+ ("rust-thiserror" ,rust-thiserror-1)
+ ("rust-windows-sys" ,rust-windows-sys-0.42))))
+ (home-page "https://github.com/EstebanBorai/local-ip-address")
+ (synopsis
+ "Retrieve system's local IP address and network interfaces/adapters")
+ (description
+ "This package provides retrieving the system's local IP address and
+network interfaces/adapters.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-local-waker-0.1
(package
(name "rust-local-waker")
@@ -39339,32 +39365,6 @@ thread-local task wakeup.")
by inspecting the system for user preference.")
(license license:expat)))
-(define-public rust-local-ip-address-0.4
- (package
- (name "rust-local-ip-address")
- (version "0.4.9")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "local-ip-address" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "1xc88i6v43rx5f5im0zadd8nl3k7wvf2lv351q20d05h5w4pzawy"))))
- (build-system cargo-build-system)
- (arguments
- `(#:tests? #f ; Integration test with local IP address.
- #:cargo-inputs (("rust-libc" ,rust-libc-0.2)
- ("rust-neli" ,rust-neli-0.5)
- ("rust-thiserror" ,rust-thiserror-1)
- ("rust-windows-sys" ,rust-windows-sys-0.42))))
- (home-page "https://github.com/EstebanBorai/local-ip-address")
- (synopsis
- "Retrieve system's local IP address and network interfaces/adapters")
- (description
- "This package provides retrieving the system's local IP address and
-network interfaces/adapters.")
- (license (list license:expat license:asl2.0))))
-
(define-public rust-lock-api-0.4
(package
(name "rust-lock-api")