summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHerman Rimm <herman@rimm.ee>2024-04-27 14:35:28 +0200
committerGuix Patches Tester <>2024-04-27 16:03:25 +0200
commit53371d86651b335af9eca18e0c5d0315a4151d8f (patch)
tree33104eb7b62c1055548f34cce76e7afcf3fdfc2e
parent2c015f299dde6ab6d38c26bcca47dd72f449a1a1 (diff)
downloadguix-patches-53371d86651b335af9eca18e0c5d0315a4151d8f.tar
guix-patches-53371d86651b335af9eca18e0c5d0315a4151d8f.tar.gz
gnu: Place rust-humantime-serde-1 in alphabetical order.
* gnu/packages/crates-io.scm (rust-humantime-serde-1): Move variable. Change-Id: Ibd2ea2715415576a438e24065863dd1fd220ed74
-rw-r--r--gnu/packages/crates-io.scm46
1 files changed, 23 insertions, 23 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 438d6b1df2..45fa63c8bc 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -32355,29 +32355,6 @@ usable by code.")
machines are still at bay.")
(license license:expat)))
-(define-public rust-humantime-serde-1
- (package
- (name "rust-humantime-serde")
- (version "1.0.1")
- (source (origin
- (method url-fetch)
- (uri (crate-uri "humantime-serde" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "0n208zzy69f7pgwcm1d0id4nzhssxn3z3zy7ki3dpkaazmnaad5c"))))
- (build-system cargo-build-system)
- (arguments
- `(#:skip-build? #t
- #:cargo-inputs
- (("rust-humantime" ,rust-humantime-2)
- ("rust-serde" ,rust-serde-1))))
- (home-page "https://github.com/jean-airoldie/humantime-serde")
- (synopsis "Humantime serialization timestamp format")
- (description
- "This package provides a Humantime serialization timestamp format.")
- (license (list license:expat license:asl2.0))))
-
(define-public rust-humansize-2
(package
(name "rust-humansize")
@@ -32462,6 +32439,29 @@ SystemTime}}.")
("rust-rand" ,rust-rand-0.4)
("rust-time" ,rust-time-0.1))))))
+(define-public rust-humantime-serde-1
+ (package
+ (name "rust-humantime-serde")
+ (version "1.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "humantime-serde" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0n208zzy69f7pgwcm1d0id4nzhssxn3z3zy7ki3dpkaazmnaad5c"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-humantime" ,rust-humantime-2)
+ ("rust-serde" ,rust-serde-1))))
+ (home-page "https://github.com/jean-airoldie/humantime-serde")
+ (synopsis "Humantime serialization timestamp format")
+ (description
+ "This package provides a Humantime serialization timestamp format.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-hyphenation-0.8
(package
(name "rust-hyphenation")