summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHerman Rimm <herman@rimm.ee>2024-04-27 14:35:31 +0200
committerGuix Patches Tester <>2024-04-27 16:03:30 +0200
commit3a81cec7900fecea35f418e827076ecbc7cbb4dc (patch)
treeabfd9e628d011d917d7675db8b63c69a8d33bfed
parentb5e80f19b7ff77181c3eacfe2947b32cccbaffd3 (diff)
downloadguix-patches-3a81cec7900fecea35f418e827076ecbc7cbb4dc.tar
guix-patches-3a81cec7900fecea35f418e827076ecbc7cbb4dc.tar.gz
gnu: Place rust-home-0.5 in alphabetical order.
* gnu/packages/crates-io.scm (rust-home-0.5, rust-hamcrest2-0.3): Move variables. Change-Id: Ibd76f91b647a26926916123ba2eb556235698e62
-rw-r--r--gnu/packages/crates-io.scm89
1 files changed, 45 insertions, 44 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 4576a80908..a86097bce1 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -30860,6 +30860,29 @@ IEEE 754-2008 binary16 type.")
higher performance on different key space sizes.")
(license (list license:asl2.0 license:expat))))
+(define-public rust-hamcrest2-0.3
+ (package
+ (name "rust-hamcrest2")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "hamcrest2" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0x8hx7jyzz2bl0wf6nir62imd26yhp6qcr7zf76cjpg05p33gy29"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-num" ,rust-num-0.2)
+ ("rust-regex" ,rust-regex-1))))
+ (home-page "https://github.com/Valloric/hamcrest2-rust")
+ (synopsis "Rust port of the Hamcrest testing library")
+ (description
+ "This package provides a port of the Hamcrest testing library.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-handlebars-5
(package
(name "rust-handlebars")
@@ -30927,50 +30950,6 @@ higher performance on different key space sizes.")
("rust-tiny-http" ,rust-tiny-http-0.11))))
(native-inputs (list protobuf))))
-(define-public rust-home-0.5
- (package
- (name "rust-home")
- (version "0.5.9")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "home" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "19grxyg35rqfd802pcc9ys1q3lafzlcjcv2pl2s5q8xpyr5kblg3"))))
- (build-system cargo-build-system)
- (arguments
- `(#:cargo-inputs (("rust-windows-sys" ,rust-windows-sys-0.52))))
- (home-page "https://github.com/rust-lang/cargo")
- (synopsis "Shared definitions of home directories")
- (description "This package provides the definition of @code{home_dir}
-used by @command{cargo} and @command{rustup}, as well as functions to find the
-correct value of @samp{CARGO_HOME} and @samp{RUSTUP_HOME}.")
- (license (list license:expat license:asl2.0))))
-
-(define-public rust-hamcrest2-0.3
- (package
- (name "rust-hamcrest2")
- (version "0.3.0")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "hamcrest2" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "0x8hx7jyzz2bl0wf6nir62imd26yhp6qcr7zf76cjpg05p33gy29"))))
- (build-system cargo-build-system)
- (arguments
- `(#:skip-build? #t
- #:cargo-inputs
- (("rust-num" ,rust-num-0.2)
- ("rust-regex" ,rust-regex-1))))
- (home-page "https://github.com/Valloric/hamcrest2-rust")
- (synopsis "Rust port of the Hamcrest testing library")
- (description
- "This package provides a port of the Hamcrest testing library.")
- (license (list license:expat license:asl2.0))))
-
(define-public rust-hash-hasher-2
(package
(name "rust-hash-hasher")
@@ -31917,6 +31896,28 @@ provided for each type.")
(sha256
(base32 "1b2h0lvksn8748764x46729ygpz8grack24spin0k29ssmr6yabr"))))))
+(define-public rust-home-0.5
+ (package
+ (name "rust-home")
+ (version "0.5.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "home" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "19grxyg35rqfd802pcc9ys1q3lafzlcjcv2pl2s5q8xpyr5kblg3"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-windows-sys" ,rust-windows-sys-0.52))))
+ (home-page "https://github.com/rust-lang/cargo")
+ (synopsis "Shared definitions of home directories")
+ (description
+ "This package provides the definition of @code{home_dir}
+used by @command{cargo} and @command{rustup}, as well as functions to find the
+correct value of @samp{CARGO_HOME} and @samp{RUSTUP_HOME}.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-hostname-0.3
(package
(name "rust-hostname")