summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHerman Rimm <herman@rimm.ee>2024-04-27 14:35:38 +0200
committerGuix Patches Tester <>2024-04-27 16:03:37 +0200
commit244c3daaa0f9589998fd2ff62dfb1eb883663b26 (patch)
tree65f8a2154d52d53a78834a54e0caf4265b69693e
parent15ab353da9e2167d59780a27490a421280d43f16 (diff)
downloadguix-patches-244c3daaa0f9589998fd2ff62dfb1eb883663b26.tar
guix-patches-244c3daaa0f9589998fd2ff62dfb1eb883663b26.tar.gz
gnu: Place rust-dyn-clone-1 in alphabetical order.
* gnu/packages/crates-io.scm (rust-dyn-clone-1): Move variable. Change-Id: I5072930b0f7a9d4e422bcff270ea157a2fdcef87
-rw-r--r--gnu/packages/crates-io.scm40
1 files changed, 20 insertions, 20 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index b857cb93b0..084defe5b8 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -22546,26 +22546,6 @@ Rust.")
"A library for running child processes.")
(license license:expat)))
-(define-public rust-dyn-clone-1
- (package
- (name "rust-dyn-clone")
- (version "1.0.17")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "dyn-clone" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "09cig7dgg6jnqa10p4233nd8wllbjf4ffsw7wj0m4lwa5w3z0vhd"))))
- (arguments
- `(#:cargo-development-inputs (("rust-rustversion" ,rust-rustversion-1)
- ("rust-trybuild" ,rust-trybuild-1))))
- (build-system cargo-build-system)
- (home-page "https://crates.io/crates/dyn-clone")
- (synopsis "Clone trait that is object-safe")
- (description "This package provides a clone trait that is object-safe.")
- (license (list license:expat license:asl2.0))))
-
(define-public rust-dwrote-0.11
(package
(name "rust-dwrote")
@@ -22593,6 +22573,26 @@ Rust.")
"This package provides lightweight binding to DirectWrite.")
(license license:mpl2.0)))
+(define-public rust-dyn-clone-1
+ (package
+ (name "rust-dyn-clone")
+ (version "1.0.17")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "dyn-clone" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "09cig7dgg6jnqa10p4233nd8wllbjf4ffsw7wj0m4lwa5w3z0vhd"))))
+ (arguments
+ `(#:cargo-development-inputs (("rust-rustversion" ,rust-rustversion-1)
+ ("rust-trybuild" ,rust-trybuild-1))))
+ (build-system cargo-build-system)
+ (home-page "https://crates.io/crates/dyn-clone")
+ (synopsis "Clone trait that is object-safe")
+ (description "This package provides a clone trait that is object-safe.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-easy-cast-0.5
(package
(name "rust-easy-cast")