summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZhu Zihao <all_but_last@163.com>2024-04-19 16:22:25 +0800
committer宋文武 <iyzsong@member.fsf.org>2024-04-19 21:17:00 +0800
commitcb31ea20ca13a0e9cde521360fe0020260900bd4 (patch)
tree571cfd7f238278d699fa7b124f2043224f421cfb
parent949f97f7f98ac74306b9de79c93790337d804e32 (diff)
downloadguix-patches-cb31ea20ca13a0e9cde521360fe0020260900bd4.tar
guix-patches-cb31ea20ca13a0e9cde521360fe0020260900bd4.tar.gz
gnu: Add font-jigmo.
* gnu/packages/fonts.scm (font-jigmo): New variable. Change-Id: Icdc619043d9f88eb413344fa9e7c2915ec86acc8 Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/fonts.scm22
1 files changed, 21 insertions, 1 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 9ec722c19c..f540c3bc9a 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -34,7 +34,7 @@
;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
;;; Copyright © 2020, 2021 Julien Lepiller <julien@lepiller.eu>
-;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
+;;; Copyright © 2020, 2024 Zhu Zihao <all_but_last@163.com>
;;; Copyright © 2020, 2021, 2022 Simen Endsjø <simendsjo@gmail.com>
;;; Copyright © 2020 Tim Van den Langenbergh <tmt_vdl@gmx.com>
;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
@@ -2963,6 +2963,26 @@ to write people's name, or for formal business situations where it is necessary
to have a detailed and proper character style.")
(license license:ipa)))
+(define-public font-jigmo
+ (package
+ (name "font-jigmo")
+ (version "20230816")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://kamichikoichi.github.io/jigmo/Jigmo-"
+ version ".zip"))
+ (sha256
+ (base32 "1higvn4qvz25hx215fs2vqlzh2d2645jbxf07yd82y09drl429jd"))))
+ (build-system font-build-system)
+ (home-page "https://kamichikoichi.github.io/jigmo/")
+ (synopsis "Font contains most CJK unified ideograph characters")
+ (description "Jigmo is a font contains all CJK unified ideograph characters
+in Unicode 15.1 standard, ranges from CJK extension A to CJK extension I.
+It is generated by the font shape data in GlyphWiki using KAGE system, Clipper
+and FontForge.")
+ (license license:cc0)))
+
(define-public font-fontna-yasashisa-antique
(package
(name "font-fontna-yasashisa-antique")