summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2024-04-20 15:12:31 +0200
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-04-22 09:54:02 +0800
commit53623ce862fb9cb02b1a6028d37c2e240eb05093 (patch)
treebe6bd61ce9d9ff71d411017f9e0daa75e646d0d5
parentfa67c2718a22348f49f279704e79925bc7488da5 (diff)
downloadguix-patches-53623ce862fb9cb02b1a6028d37c2e240eb05093.tar
guix-patches-53623ce862fb9cb02b1a6028d37c2e240eb05093.tar.gz
gnu: qmmp: Add missing inputs.
* gnu/packages/music.scm (qmmp): Add inputs to support unpacking skins. [inputs]: Add tar and unzip. [arguments]: Add phase to set absolute paths to these programs. Change-Id: I79a6530ad27b474ecc64e5b7de36e0370595bc69 Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn>
-rw-r--r--gnu/packages/music.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 86b46bfdfe..df3ff38b4a 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -615,7 +615,15 @@ you create custom user interfaces for your MIDI hardware.")
(build-system qt-build-system)
(arguments
(list #:qtbase qtbase
- #:tests? #f)) ; there are no tests
+ #:tests? #f ; there are no tests
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'set-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/plugins/Ui/skinned/skinreader.cpp"
+ (("\"(tar|unzip)\"" _ name)
+ (let ((file (string-append "/bin/" name)))
+ (string-append "\"" (search-input-file inputs file) "\"")))))))))
(inputs
;; Missing optional inputs:
;; libsidplay2 ; input plugin
@@ -645,6 +653,8 @@ you create custom user interfaces for your MIDI hardware.")
qttools
soxr
taglib
+ tar ; for loading skins
+ unzip ; for loading skins
wavpack
wildmidi))
(native-inputs