summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-01 15:37:17 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-01 15:37:45 +0200
commite2ba58a67f8ebf1e9c0b1bc082db79ffae42a46f (patch)
tree16800a93ced4811a4b254705c3014081cef7526a
parent4115590ed1f4a95e52a687d0d0a4bab69e18f4d7 (diff)
downloadguix-patches-e2ba58a67f8ebf1e9c0b1bc082db79ffae42a46f.tar
guix-patches-e2ba58a67f8ebf1e9c0b1bc082db79ffae42a46f.tar.gz
gnu: Add emacs-ob-asymptote.
* gnu/packages/emacs-xyz.scm (emacs-ob-asymptote): New variable. Change-Id: I022557ed6eb6473e26842a5e72d9abdd1d516d35
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 77e18a582c..411d7c0a1d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9099,6 +9099,32 @@ minibuffer to enable editing the minibuffer input in another buffer with
source code using IPython.")
(license license:gpl3+)))
+(define-public emacs-ob-asymptote
+ (package
+ (name "emacs-ob-asymptote")
+ (version "1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://elpa.gnu.org/packages/ob-asymptote-"
+ version ".tar"))
+ (sha256
+ (base32 "1hmqbkrqg18w454xg37rg5cg0q3vd0b0fm14n5chihqrwwnwrf4l"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/hurrja/ob-asymptote")
+ (synopsis "Babel functions for Asymptote")
+ (description
+ "This package provides Org Babel support for evaluating Asymptote source
+code. This differs from most standard languages in that:
+@itemize
+@item there is no such thing as a ``session'' in Asymptote,
+@item we are generally only going to return results of type @code{file},
+@item we are adding the @code{file} and @code{cmdline} header arguments, if
+file is omitted then the @samp{-V} option is passed to the @command{asy}
+command for interactive viewing.
+@end itemize")
+ (license license:gpl3+)))
+
(define-public emacs-ob-async
(package
(name "emacs-ob-async")