summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve George <steve@futurile.net>2024-04-26 13:42:04 +0200
committerLudovic Courtès <ludo@gnu.org>2024-05-04 19:14:26 +0200
commit6a23664cd869697eed8939312e986c862dd40b6d (patch)
treebc2b517075c32099516e387005a6caf76a30f2d3
parente175175a11ea0ac5d036d13b341f99dbb4765975 (diff)
downloadguix-patches-6a23664cd869697eed8939312e986c862dd40b6d.tar
guix-patches-6a23664cd869697eed8939312e986c862dd40b6d.tar.gz
gnu: Add perl-digest-perl-md5.
* gnu/packages/perl.scm (perl-digest-perl-md5): New variable. Change-Id: Ic656fef7bbc77790d114812f0c9dcafa1586e357 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/perl.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index a72c3af765..9f1a9fdfcc 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -4094,6 +4094,26 @@ input a message of arbitrary length and produces as output a
128-bit \"fingerprint\" or \"message digest\" of the input.")
(license (package-license perl))))
+(define-public perl-digest-perl-md5
+ (package
+ (name "perl-digest-perl-md5")
+ (version "1.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/D/DE/DELTA/Digest-Perl-MD5-" version
+ ".tar.gz"))
+ (sha256
+ (base32 "1cfrxkzazxdg4prdfcfd9b33bvyav1xim2vxj07gni8gf6hwn03i"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/release/Digest-Perl-MD5")
+ (synopsis "Perl Implementation of Rivest's MD5 algorithm")
+ (description "This @code{Digest::Perl::MD5} has the same interface as the
+much faster @code{Digest::MD5}, but it's a pure Perl implementation of MD5.
+Because of this it is slow but it works without C code.")
+ (license license:perl-license)))
+
(define-public perl-digest-sha
(package
(name "perl-digest-sha")