summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve George <steve@futurile.net>2024-04-26 13:41:57 +0200
committerLudovic Courtès <ludo@gnu.org>2024-05-04 19:14:25 +0200
commit3ca4d48322f6ac7fa503fcb0b1ed15db8e9fc990 (patch)
tree4f6a2ff58dbb9c477d6b075fd005649cf09939e2
parent96a0a7431ff216d1a3c8ca7858e150e557aebe4d (diff)
downloadguix-patches-3ca4d48322f6ac7fa503fcb0b1ed15db8e9fc990.tar
guix-patches-3ca4d48322f6ac7fa503fcb0b1ed15db8e9fc990.tar.gz
gnu: aqbanking: Update to 6.5.4.
* gnu/packages/gnucash (aqbanking): Update to 6.5.4. Change-Id: I8d10562e1fc8517bee946792ad1ac901a26137d5 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/gnucash.scm71
1 files changed, 36 insertions, 35 deletions
diff --git a/gnu/packages/gnucash.scm b/gnu/packages/gnucash.scm
index d8d13f9780..d5681ed86d 100644
--- a/gnu/packages/gnucash.scm
+++ b/gnu/packages/gnucash.scm
@@ -276,42 +276,43 @@ applications and libraries. It is used by AqBanking.")
(license license:lgpl2.1+))))
(define-public aqbanking
- (package
- (name "aqbanking")
- (version "6.3.2")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://www.aquamaniac.de/rdm/attachments/"
- "download/386/aqbanking-" version ".tar.gz"))
- (sha256
- (base32 "061l7qja7x557650kphbg1gzxc52a7557nibgdhv5jwqf8pv8ym9"))))
- (build-system gnu-build-system)
- (arguments
- `(;; Parallel building fails because aqhbci is required before it's
- ;; built.
- #:parallel-build? #f
- #:phases
- (modify-phases %standard-phases
- ;; Embed the package version instead of the build date
- (add-after 'unpack 'use-version-instead-of-date
- (lambda _
- (substitute*
- "src/libs/plugins/backends/aqhbci/header.xml.in"
- (("@DATETIME@") ,version)))))))
- (propagated-inputs
- (list gwenhywfar))
- (inputs
- (list gmp xmlsec gnutls))
- (native-inputs
- (list pkg-config gettext-minimal libltdl))
- (home-page "https://www.aquamaniac.de")
- (synopsis "Interface for online banking tasks")
- (description
- "AqBanking is a modular and generic interface to online banking tasks,
+ (let ((attachid "499")) ;; file attachid changes for each version
+ (package
+ (name "aqbanking")
+ (version "6.5.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.aquamaniac.de/rdm/attachments/"
+ "download/" attachid "/aqbanking-" version ".tar.gz"))
+ (sha256
+ (base32 "16dc63gav0b4rmwj0clqilfpz4hlidx59x1qcr38wwghfspcw5hd"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(;; Parallel building fails because aqhbci is required before it's
+ ;; built.
+ #:parallel-build? #f
+ #:phases
+ (modify-phases %standard-phases
+ ;; Embed the package version instead of the build date
+ (add-after 'unpack 'use-version-instead-of-date
+ (lambda _
+ (substitute*
+ "src/libs/plugins/backends/aqhbci/header.xml.in"
+ (("@DATETIME@") ,version)))))))
+ (propagated-inputs
+ (list gwenhywfar))
+ (inputs
+ (list gmp xmlsec gnutls))
+ (native-inputs
+ (list pkg-config gettext-minimal libltdl))
+ (home-page "https://www.aquamaniac.de")
+ (synopsis "Interface for online banking tasks")
+ (description
+ "AqBanking is a modular and generic interface to online banking tasks,
financial file formats (import/export) and bank/country/currency information.
AqBanking uses backend plugins to actually perform the online tasks. HBCI,
OFX DirectConnect, YellowNet, GeldKarte, and DTAUS discs are currently
supported. AqBanking is used by GnuCash, KMyMoney, and QBankManager.")
- ;; AqBanking is licensed under the GPLv2 or GPLv3
- (license (list license:gpl2 license:gpl3))))
+ ;; AqBanking is licensed under the GPLv2 or GPLv3
+ (license (list license:gpl2 license:gpl3)))))