summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authordan <i@dan.games>2024-04-21 16:29:29 +0800
committerGuix Patches Tester <>2024-04-21 11:54:09 +0200
commited3b58ab849803bcd7a6274a773e4b003c806053 (patch)
tree5182fab7baa58742367667a28ca926c5203c67e5
parent8600726d388da2c1e20820c8835953d6844a0d87 (diff)
downloadguix-patches-ed3b58ab849803bcd7a6274a773e4b003c806053.tar
guix-patches-ed3b58ab849803bcd7a6274a773e4b003c806053.tar.gz
gnu: Add libliftoff.
* gnu/packages/freedesktop.scm (libliftoff): New variable. Change-Id: Ia66bb09db6b09c63fbc6223f58d6a0ebf6f4c546
-rw-r--r--gnu/packages/freedesktop.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 339297c087..d0c14e8077 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -35,6 +35,7 @@
;;; Copyright © 2023 Alex Devaure <ajadevaure@gmail.com>
;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2024 dan <i@dan.games>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3234,3 +3235,25 @@ notifies the user using any notification daemon implementing
"Waypipe is a proxy for Wayland clients, with the aim of
supporting behavior like @samp{ssh -X}.")
(license license:expat)))
+
+(define-public libliftoff
+ (package
+ (name "libliftoff")
+ (version "0.4.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.freedesktop.org/emersion/libliftoff")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256 (base32 "1ikjp638d655ycaqkdnzhb12d29kkbb3a46lqhbhsfc8vsqj3z1l"))))
+ (build-system meson-build-system)
+ (inputs (list libdrm))
+ (native-inputs (list pkg-config))
+ (home-page "https://gitlab.freedesktop.org/emersion/libliftoff")
+ (synopsis "Lightweight KMS plane library")
+ (description "libliftoff eases the use of KMS planes from userspace
+without standing in your way. Users create \"virtual planes\" called layers,
+set KMS properties on them, and libliftoff will pick hardware planes for these
+layers if possible.")
+ (license license:expat)))