summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-03 17:56:40 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-30 21:36:11 +0100
commitb4306b66fd94910ee3ff70edb8bccd38639d5e99 (patch)
tree486807c9dfb683dff4834e54608b8789ee786c72
parent1968ad4036f4df9ebdc7c8823f8fdc241c53e16e (diff)
downloadguix-patches-b4306b66fd94910ee3ff70edb8bccd38639d5e99.tar
guix-patches-b4306b66fd94910ee3ff70edb8bccd38639d5e99.tar.gz
gnu: python-ginga: Set HOME for sanity check.
* gnu/packages/astronomy.scm (python-ginga) [arguments] <#:phases>: Add 'set-home phase. Change-Id: I7fc9b043ae8ac465645215dabc9d8643b8e08fe2
-rw-r--r--gnu/packages/astronomy.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 8bcc87b1a2..1f4a437e5e 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -723,7 +723,13 @@ series in Python.")
(lambda _
(substitute* "setup.cfg"
;; packaging>=23.1
- ((">=23.1") ">=21.3")))))))
+ ((">=23.1") ">=21.3"))))
+ (add-before 'check 'set-home
+ (lambda _
+ ;; Relax matplotlib warning: ... because the default path
+ ;; (/homeless-shelter/.config/matplotlib) is not a writable
+ ;; directory ...
+ (setenv "HOME" "/tmp"))))))
(propagated-inputs
(list opencv
python-astropy