summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-03 17:43:35 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-30 21:36:12 +0100
commitb332e7b85e56957e494dacf5f15edd6f4e8464b9 (patch)
tree2fd007c6d780997d98b05c9e78fb64a560ceb927
parentb4306b66fd94910ee3ff70edb8bccd38639d5e99 (diff)
downloadguix-patches-b332e7b85e56957e494dacf5f15edd6f4e8464b9.tar
guix-patches-b332e7b85e56957e494dacf5f15edd6f4e8464b9.tar.gz
gnu: python-gatspy: Refresh package style.
* gnu/packages/astronomy.scm (python-gatspy): Adjust indentetion. [arguments]: Use #~ qutation style. <#:test-flags>: Activate tests for supersmoother. [propagated-inputs]: Add python-supersmoother. Change-Id: Ibbaae0f87693f5f4aa6e3f92d567881ad58dbfba
-rw-r--r--gnu/packages/astronomy.scm41
1 files changed, 21 insertions, 20 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 1f4a437e5e..670e8510d8 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -675,33 +675,34 @@ CFITSIO library. Among other things, it can
(package
(name "python-gatspy")
(version "0.3")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "gatspy" version))
- (sha256
- (base32
- "1gw2z6x8nikvnw2gkdl70gr81cwczd1pd7v8ry2kjn6k4kssrfav"))))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "gatspy" version))
+ (sha256
+ (base32 "1gw2z6x8nikvnw2gkdl70gr81cwczd1pd7v8ry2kjn6k4kssrfav"))))
(build-system pyproject-build-system)
(arguments
(list
- #:phases
- '(modify-phases %standard-phases
- ;; Tests need this
- (add-before 'check 'set-HOME
- (lambda _ (setenv "HOME" "/tmp"))))
#:test-flags
- '(list "-k"
- (string-append
- ;; These tests require internet access
- "not test_download_data.py"
- ;; XXX: we don't have supersmoother
- " and not test_supersmoother.py"))))
- (propagated-inputs (list python-astroml python-numpy python-scipy))
+ ;; These tests require internet access
+ #~(list "-k" "not test_download_data.py")
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Tests need this
+ (add-before 'check 'set-HOME
+ (lambda _ (setenv "HOME" "/tmp"))))))
+ (propagated-inputs
+ (list python-astroml
+ python-numpy
+ python-scipy
+ python-supersmoother))
(native-inputs (list python-pytest python-nose python-setuptools-scm))
(home-page "https://github.com/astroml/gatspy")
(synopsis "General tools for astronomical time series in Python")
- (description "This package provides general tools for astronomical time
-series in Python.")
+ (description
+ "This package provides general tools for astronomical time series in
+Python.")
(license license:bsd-2)))
(define-public python-ginga